Having a problem with vulcan turbo.... - General Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Having a problem with vulcan turbo....
Friday, February 05, 2010 7:34 AM
So i ordered a intake manifold for my ecotec..It was supposed to be here 2 weeks ago...ive called them prolly 8 million times and have left tons of messeges and never seem to get anyone to awnser..ive also emailed them a bunch of times and no awnser...so if anyone has any ties with them can someone figure out whats going on cause if i cant get my manifold soon guess im gonna have to find a way to get my money back




13.1 @ 115

Re: Having a problem with vulcan turbo....
Sunday, February 07, 2010 5:45 PM
change your sig so your name doesn't blink





Re: Having a problem with vulcan turbo....
Monday, February 08, 2010 6:37 PM
best reply reward goes too. . . . . . ..






















WEEBEL!!!!! way to nominate yourself for DBOTY Award!!!!!



JBO Stickers are back!!!! Click Me!!
Re: Having a problem with vulcan turbo....
Monday, February 08, 2010 9:41 PM
i was kinda thinking that but just ignored it




13.1 @ 115
Re: Having a problem with vulcan turbo....
Tuesday, February 09, 2010 10:23 AM
Vulcan started off real nice and all about business when they signed up on the site last year. Now they got in good with everybody they resort back to their old ways- aka exploited....

I was one of the luck ones last year that got their coolant tank without any problems.

I hope you get your mani, or your money back real soon.











~2014 New Z under the knife, same heart different body~
______________________
WHITECAVY no more
2012 numbers - 4SPD AUTOMATIC!!
328 HP
306 TQ
Re: Having a problem with vulcan turbo....
Tuesday, February 09, 2010 10:27 AM
Brad (flatblackfire) wrote:

best reply reward goes too. . . . . . ..


WEEBEL!!!!! way to nominate yourself for DBOTY Award!!!!!



guess you can nominate yourself then too for DBOTY


Mike Barr,
how did you pay for this manifold? credit card?



Im a Xbox 360 fanboy...and damn proud of it!!
Re: Having a problem with vulcan turbo....
Wednesday, February 10, 2010 3:38 AM
WHITECAVY wrote:

Vulcan started off real nice and all about business when they signed up on the site last year. Now they got in good with everybody they resort back to their old ways- aka exploited...


'Fool me once, shame on you; fool me twice, shame on me'

They are not getting a second chance from me....well exploited from back in the day.




Re: Having a problem with vulcan turbo....
Wednesday, February 10, 2010 9:38 AM
Yes I paid with my bank car...

They actually awnsered there phone yesterday and said it should be here Thursday or Friday...so I said if its not I'm getting my money back and your company can kiss my ass




13.1 @ 115
Re: Having a problem with vulcan turbo....
Wednesday, March 10, 2010 6:48 PM
no one listens on this site.







Re: Having a problem with vulcan turbo....
Saturday, March 13, 2010 10:59 AM
Jake wrote:

no one listens on this site.


after seeing the way wade was treated over the m62 setup... no f'ing way.



We all need somebody to believe in something...
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search