New owner, need some help please - General Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
New owner, need some help please
Thursday, April 14, 2016 10:04 AM
Hey guys, I'm new here, and a new Cavalier owner.

What I have:
2002 Cavalier, 2 door, 2200 SFI, 4 speed auto, soft ride suspension

Bought 2 months ago, 158k, $550

Since purchase I've installed new front quick struts, new upper engine mount and lower torque mount (stock but going to get the prothane set), new alternator, Optima red top, NGK Iridium IX plugs, Autolite wires, fresh oil, window regulators, and have been fixing a long list of other problems to be expected with a really cheap car. Also, was told the trans fluid and filter we're changed just before I bought it

Quick side note, I work at Advance Auto, so I'm able to throw all these parts at it very cheap, still under $1000 invested

I have 4 main issues I'm hoping you can help with, and I hope I'm not cramming too much into one post...

1. Driver door hinges. The door is sagging and I have the hinge pin set, looks to be the most complicated pin set I've ever seen that's actually rebuildable. I've tried every shop anywhere, nobody around has ever done it. Do I have to remove the entire door?

2. Throttle lag. I've got it tuned up and it runs great, the last issue for me is the throttle response and returning to idle. Seems to me like I have slowest idle air control valve that's ever happened. Not so much throttle increase, but decrease takes a long time, and every time it goes back to idle it drops 20-30 rpms below, then back to set idle. Is replacing the IAC valve going to take care of this, or is that just how these engines are?

3. Loud clunk from front right. Shifting from reverse to drive, vice versa, and heavy acceleration then deceleration. Basically anytime the engine and trans move. Hoping this is a common issue that someone can point out to me, basic inspection when I jacked it up to replace the lower engine mount didn't reveal anything that looked loose or worn

4. Steering rack bushings? When I accelerate, the steering pulls right, opposite when I brake, wheel stays straight when maintaining speed. When the front end is lifted, and I move the tire with my hands, both ties more about 1/4" , with no movement in the tie rod ends. Seems like the whole rack is moving. Is this common?

I know this is a lot to read through, I tried to include all info I think is necessary. I will really appreciate it if you guys can help me figure these issues out, thanks so much in advance
Attachments
aviary-image-1460650450160.jpeg (331k)


Re: New owner, need some help please
Thursday, April 14, 2016 11:20 AM
Hey Steve,

This forum is pretty slow now-a-days but you might get some feedback on this still...maybe. I would try searching the forum like crazy to find some of these but let me see what I can solve for you quick.

The hinges are sort of involved; you have to grind off the head of the pins to allow them to be punched down and out. Then you replace all the bushings in there and install the aftermarket kit that you purchased. The coupe and 4-door use the same hinge assembly so the coupe will suffer that sag after many years. Mine is in need of this repair as well.

My 02 LSS does the same thing on the throttle decrease. These cars like to rev hang decently long IMO, at least mine always has (it's a 5-speed), and it will typically come down strong once it does and bounce a little before returning to a solid idle. Either its the way the car is or we've got a similar issue

The loud clunk issue could be freaking anything under there but my first thought based on your description would be that it's either in the transmission itself or has something to do with a trans mount or bushing. If everything around the tranny looks solid then I would look at the suspension. Do your usual suspension tests (pushing down each corner of the car and seeing how it responds adding and removing weight) and see if you notice anything. Could be a spring/strut, they like to make all kinds of stupid noises when they get worn out.

I'm at a loss for your steering issue but I can tell you that there's certainly not expected behavior to have steering play like what you're describing. The one thing I've loved about my car since I got it is how tight the steering feels. Maybe get an alignment and let your mechanic know what you're feeling and see if they can find anything in the process.

Good luck buddy, sorry I couldn't be of more concrete help. Let me know if you figure any of this out/how it goes. I'd be interested to see pics of that hinge replacement. It might even be somewhere on the site that I haven't found yet.




2002 Blue LS Sport Coupe 5-speed
My Paint Restoration Project --> http://www.j-body.org/forums/read.php?f=11&i=170933&t=170933

Re: New owner, need some help please
Thursday, April 14, 2016 10:11 PM
T!M8!T Online
Hey yes there's a few of us around willing to help. Allot of the forums pics don't work but there is info around. I had a clunking issue too coming from a bad strut in the rear and worn tie rods. It also pulled the car around while driving. Check any mounts or bushings


ReD RaiN
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search