Theft System Light On: Car Won't Start - Maintenance and Repair Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Theft System Light On: Car Won't Start
Sunday, August 07, 2011 8:54 PM
As the title states, my theft system light is on and my car will not start.

The problem occurred this morning and is ongoing. I've researched this issue quite a bit, but I haven't been able to solve the issue.

Initially, I can't get the car to start and it gives the tell-tale signs of fuel being cut to the injectors. It cranks and turns, but with no fuel immediately dies.

The only "warning" lights I'm getting are a flashing Theft System Light, a solid Battery Light, and a solid Oil Light (oil light doesn't really concern me).

After it dies, it won't restart no matter how many times I try immediately afterward.

If I leave the key in long enough for the Theft System Light to turn off (5-10 Minutes), it will immediately start up on the next try and drive fine. I did notice when it starts that the Theft System Light stays solid for a good 5 seconds before turning off, which is longer than I remember.

Upon turning the car off, the cycle repeats and I can not start the car again and the Theft System Light flashes continuously even after taking the key out.

I tried the 10-15 Minute reset procedure, but it only seems to be working temporarily (good enough for one start). I also didn't "hear" the computer relearning as described in the instructions listed here, although I'm not really sure what exactly I should be hearing.

What could be the problem? Please help! I don't want to be stranded anywhere.

1997 Pontiac Sunfire Coupe
2.2 Auto
Manual Doors and Windows
No Remote Start

I should mention there is what appears to be an aftermarket kill switch installed branded "ProLock," which is like a "chip" that can be removed to prevent the car from starting, but this doesn't appear to be the problem. I don't think the Theft System Light would indicate a malfunction with this aftermarket system, correct?


1997 Pontiac Sunfire

Re: Theft System Light On: Car Won't Start
Monday, August 08, 2011 8:59 PM
Anyone? Please help!

I've also noticed that when the car stalls, I don't really have to follow the re-learn procedure to get it running again.

I can take the key out while the theft system light is blinking. The theft light will turn off after exactly 10 minutes, and then the car will restart.


1997 Pontiac Sunfire
Re: Theft System Light On: Car Won't Start
Monday, August 08, 2011 9:16 PM
sounds like ignition cyl issue. It could be tripping the theft system in contact with the points ignition and key.
Re: Theft System Light On: Car Won't Start
Tuesday, August 09, 2011 3:39 PM
rich weeks wrote:

sounds like ignition cyl issue. It could be tripping the theft system in contact with the points ignition and key.


How would I go verifying this is the problem?

I've also noticed that after my 15 minute drive to work, I can start the car after turning it off within the first 30 seconds or so.

Why would this be?

If I let it sit off for longer periods of time without doing the reset the last time I was in it without turning it on afterward, it won't turn on.


1997 Pontiac Sunfire
Re: Theft System Light On: Car Won't Start
Sunday, August 14, 2011 10:18 PM
Does anyone know if bypassing Pass Lock the way alarm companies install remote starts will rid me of this start up issue?


1997 Pontiac Sunfire
Re: Theft System Light On: Car Won't Start
Sunday, August 14, 2011 10:38 PM
There is a harness grounded to the battery tray in the engine bay. I'm pretty sure the passlock system grounds through there and if it's corroded, it doesn't work correctly.



Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search