My 89 cavi has me stumped - Maintenance and Repair Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
My 89 cavi has me stumped
Saturday, September 10, 2011 9:36 AM
Hi, I have a 89 Cavi(Nicks old car) with a 3400 engine and it wouldn`t start, I messed with the cps on the block, it started. Drove it for a while and it did it again. I replace the cps on the side of the block. wouldn`t start. Waited a little while and it started and was fine since. This morning, I went to start it and again it will not start. It cranks but no spark again. Any ideas? Thank you thank you!

Re: My 89 cavi has me stumped
Monday, September 12, 2011 7:09 AM
You check the distributor? Spark plugs and wires? That's what I would check for spark before replacing sensors. Especially the distributor.
Re: My 89 cavi has me stumped
Monday, September 12, 2011 6:42 PM
It doesn`t have a distributor.
Re: My 89 cavi has me stumped
Monday, September 12, 2011 6:50 PM
Sounds like the ICM is going bad. It's what the coils sit on.


- Your not-so-local, untrained, uncertified, backyard mechanic. But my @!#$ runs
Re: My 89 cavi has me stumped
Monday, September 12, 2011 8:57 PM
Thank you, thank you. I will try that.
Re: My 89 cavi has me stumped
Monday, September 12, 2011 10:11 PM
80s and no distributor? hmm, sorry, I'm not a second gen guy.
Re: My 89 cavi has me stumped
Monday, September 12, 2011 10:23 PM
2nd gen didn't come with a 3400 either.


- Your not-so-local, untrained, uncertified, backyard mechanic. But my @!#$ runs
Re: My 89 cavi has me stumped
Tuesday, September 13, 2011 8:52 AM
I don't know what I was thinking. Haha I feel like an idiot. Now that I have come to my senses, I would agree with you, and check the icm first.
Re: My 89 cavi has me stumped
Friday, September 16, 2011 6:17 PM
I'd lean on the ICM or Coil Packs on that. GM was nice enough to mount them right under the exhaust manifold so they get exposed to all kinda heat.





i find it amusing that SHOoff has nothing better to do but follow me around & be an unhelpful dick in even cross-forum. - Jon Mick
Re: My 89 cavi has me stumped
Friday, September 16, 2011 8:07 PM
SHOoff wrote:

I'd lean on the ICM or Coil Packs on that. GM was nice enough to mount them right under the exhaust manifold so they get exposed to all kinda heat.


That might be the issue, that is if it still had the old 2.8 MPFI....... this is 3400 swapped, coils on top.
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search