2200 98 injectors - Performance Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
2200 98 injectors
Thursday, May 22, 2014 3:25 PM
Hey guys. Ive recently been having a problem going through injectors. its been pretty sudden on my oval track cav. Its only been on cylinder 1 and 2. but ive been through 3 injectors in the past 3 races. I've been pretty curious on what could maybe be causing this. Any insight would be nice, im planning on dropping the tank and changing the filter in a couple days. and to mention ive had my scanner on it every time one went and it still said they all had proper pressures and voltage. Anything helps, thanks guys!

Re: 2200 98 injectors
Thursday, May 22, 2014 3:38 PM
Dirt For Life wrote:

Hey guys. Ive recently been having a problem going through injectors. its been pretty sudden on my oval track cav. Its only been on cylinder 1 and 2. but ive been through 3 injectors in the past 3 races. I've been pretty curious on what could maybe be causing this. Any insight would be nice, im planning on dropping the tank and changing the filter in a couple days. and to mention ive had my scanner on it every time one went and it still said they all had proper pressures and voltage. Anything helps, thanks guys!
Oh yeah and by the way, i do have 4 ecotec injectors in it. they were what I had for backups and they do the job!
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search