oil pressure ? - Performance Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
oil pressure ?
Wednesday, April 05, 2006 2:42 PM
ok i finally finished getting the oil pressure guage installed. THe guage goes from 1 - 150psi and is mechanical. What number would be normal for a turboed cavalier and what is it acctually reading. Thanks for the info




Re: oil pressure ?
Wednesday, April 05, 2006 2:56 PM
well it would actually be reading oil pressure


the pressure should be no less than 10 psi , and can be higher than 100 psi when cold

anything inbetween and your safe

gm states 10psi per 1000 rpm (atleast that is what i remember it being last time i looked)








Re: oil pressure ?
Wednesday, April 05, 2006 3:27 PM
97cavie24ls(JDM&00s/c sedans™) wrote:

well it would actually be reading oil pressure


the pressure should be no less than 10 psi , and can be higher than 100 psi when cold

anything inbetween and your safe

gm states 10psi per 1000 rpm (atleast that is what i remember it being last time i looked)


I'm not sure how accurate that is. I know on a 2.4 when nice and warmed up WOT at 6200 RPM you are between 45-52psi. That would not equal 10psi per 1000rpm's.



FU Tuning



Re: oil pressure ?
Wednesday, April 05, 2006 3:50 PM
John Higgins wrote:

97cavie24ls(JDM&00s/c sedans™) wrote:

well it would actually be reading oil pressure


the pressure should be no less than 10 psi , and can be higher than 100 psi when cold

anything inbetween and your safe

gm states 10psi per 1000 rpm (atleast that is what i remember it being last time i looked)


I'm not sure how accurate that is. I know on a 2.4 when nice and warmed up WOT at 6200 RPM you are between 45-52psi. That would not equal 10psi per 1000rpm's.


yes quoted is 10psi per 1000rpm, however thats a "rule of thumb" and most of the time isnt met in the higher rpms. the 2.4L's oiling system also isnt the best.

on the new 2.4L that i built with the 2.3L pump swap i did 75psi cold @ idle, 110psi @ 2500rpm, warmed up it did 62psi @ idle and around 98 or so @ 2500 rpm and rock solid till redline.


_______________________
** Flat Broke Racing Inc.**
Re: oil pressure ?
Wednesday, April 05, 2006 4:29 PM
Ouch!! thats alot of power going to waste.Too much pressure just causes the motor to eat up horsepower and puts additional stress on the accessory drive system.

If you can maintain about 45psi+ from cruising rpm up you'll be fine.





Re: oil pressure ?
Wednesday, April 05, 2006 5:05 PM
at crusing im around 50psi and at high boost it only goes up to about 70psi

does that sound right?



Re: oil pressure ?
Wednesday, April 05, 2006 6:14 PM
Casper wrote:

at crusing im around 50psi and at high boost it only goes up to about 70psi

does that sound right?


You have a Ecotec so I'm not 100% what they read. I can only account for the 2.4 with stock bottem end.



FU Tuning



Re: oil pressure ?
Wednesday, April 05, 2006 6:29 PM
I'm N/A with my Ecotec...and warmed up at WOT...I get like 80-90 at all times....usually though at idle I may drop down to around 55-70 range.

But like I said I'm only N/A...but maybe it helps you out.






Silver Stripey makes your Day!
Re: oil pressure ?
Wednesday, April 05, 2006 8:11 PM
Yea that did help thanks



Re: oil pressure ?
Thursday, April 06, 2006 12:11 AM
With the Eco, where is your sender hooked up. When mine gets fully warmed up I get between 25 and 50 psi at idle. It's NA and running Mobil 1 oil.
Re: oil pressure ?
Thursday, April 06, 2006 3:51 AM
My 2.4 runs about 40-50 at 60mph and from 65-78 at WOT. That is after it warms up. At idle I'm around 8-12 psi. "600rpm"








Re: oil pressure ?
Thursday, April 06, 2006 5:42 AM
M. Mathhews. - My sender is hooked up in the stock location. Took out my stock sending unit and put in a T-Fitting in the stock location. Both senders are running off that tee. Where is yours located? I wonder if it makes a difference or not? Did you drill a hole somewhere else?

This makes me go....Hmmmm......






Silver Stripey makes your Day!
Re: oil pressure ?
Thursday, April 06, 2006 5:05 PM
MadJack wrote:

Ouch!! thats alot of power going to waste.Too much pressure just causes the motor to eat up horsepower and puts additional stress on the accessory drive system.

If you can maintain about 45psi+ from cruising rpm up you'll be fine.


no not really... keep in mind this is taken with 10/30 oil, not that it will make much if any difference... and it'll be fine....


_______________________
** Flat Broke Racing Inc.**
Re: oil pressure ?
Thursday, April 06, 2006 9:38 PM
Well, if you have the 2.3l oil pump conversion done, cold the pressure is at 90 psi, hot, idle, I am at 30 psi, and wot I am around the 60-70 psi.


http://www.saskjbody.org/
http://www.cardomain.com/memberpage/449879/1
Re: oil pressure ?
Thursday, April 06, 2006 10:28 PM
What numbers are you showing at idle and, say, 3000 rpm when you first start? Same question after the engine has reached normal operating temp?





Re: oil pressure ?
Wednesday, June 18, 2014 7:05 PM
I just built had my motor built(2.4 with a 2.3 oil pump) car was idling running fine at 2000 rpms
but i started to get timing chain noise and now i have no oil pressure
the motor is ok it did not get hurt..
but i have no oil pressure changed the tensioner and still no pressure?
the oil pump was used
Re: oil pressure ?
Thursday, June 19, 2014 3:22 AM
Possibly the relief valve is stuck open or some plug (?) was ejected. Don't screw around -- buy a new pump and install it. Your time is valuable too. If you got this pump from a used engine maybe that is why the engine was taken out of service or it was contaminated by debris. Who knows.





Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search