Turbos???? - First Generation Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Turbos????
Thursday, February 16, 2017 5:58 PM
How many Turbos are still out the on the forum? I know Paul and I have 84 convertibles, but how many are still out there watching? What have you got??




Re: Turbos????
Friday, March 03, 2017 8:36 PM
I just picked up an 88 Sunbird gt vert auto yesterday, its been sitting for 12ish years and has 67,000 original miles, no rust on body except for the bottom of doors(bad enough that they will need replaced) unfortunate because the car has all original paint ( red) in great shape. Very excited to jump into this project! And if anyone has red doors for sale I'll buy them .
Re: Turbos????
Saturday, March 04, 2017 7:59 AM
I had to fix the bottom of my right door. The 86 convertible was solid. That car was in dry storage for years.



Re: Turbos????
Sunday, March 05, 2017 9:45 AM
Yours are gorgeous Philip! Any suggestions before I fire this thing up after sitting for 10-plus years? All the fluids are good oil is spotless, I'm just not sure about the turbo. Should I just disconnect the coil wire and turn the motor over until I see all pressure build and then try and fire it?
Re: Turbos????
Sunday, March 05, 2017 9:46 AM
Also I already pulled the gas tank down cleaned it put a new fuel pump in and all that jazz, fresh fuel is in it.
Re: Turbos????
Sunday, March 05, 2017 4:40 PM
I would absolutely crank it over and check oil pressure before firing. Also I hope spotless means you changed it after sitting all that time and fresh coolant. Those two things are the lifeblood of the turbo. I would also pull the intake hose and check for play in the turbo intake shaft as well. When you crank it the first time let it idle and warm up good be sure everything flushes with hot oil before running it out the first time. just my recommendations. Good Luck!



Re: Turbos????
Sunday, March 05, 2017 4:42 PM
Post a pick of your find. I love the pop-up headlight covers.



Re: Turbos????
Sunday, March 05, 2017 5:21 PM
The oil was clean, sorry when I mean by spotless is I already changed that too. I have everything ready to go and have cranked it over, the problem having now is I have no fuel pump running. The fuse seems to be good and when I flick the key for and I can hear a couple of relays under the hood clicking, I don't know which relay is the fuel pump relay though. I see one on the driver side firewall and looks like two or three that are located in front of the passenger side firewall close to the blower motor. Do you know which one of these is the fuel pump relay? Thanks again for your time Philip. Roger.
Re: Turbos????
Sunday, March 05, 2017 5:23 PM
I'll get some pics loaded up once I figure out how to get them loaded on here, seems to be very complicated to load a picture up here.
Re: Turbos????
Monday, March 06, 2017 4:44 AM
I will look at my manuals, I have an 84 and 85 manuals. I would check for 12v back at the pump wiring back at the tank. The other common thing that happens is the short hose in the tank that connects to the pump deteriorates and breaks after sitting and results in no or very low fuel pressure and no starts. That will mean drop the tank as well. But you had the tank out, was all that good?



Re: Turbos????
Monday, March 06, 2017 10:17 AM
Remarkably that tank was in decent shape and so is the sending unit, I clean the tank and put a brand new fuel pump in it. I found out the relay is on the passenger side fender by the firewall there are three of them there. I changed the one out that had a purple wire going to it which apparently was the fuel pump and the pump started working. I turn the car over without the coil wire on it till I saw pressure, put the coil wire back on it it fired right up I had to wait about 20 to 25 minutes of it idling for to the fuel injectors to start firing but they are all firing now. I took off the hose for the fuel rail and Shop brake cleaner into the fuel rail reattach the hose and let it sit in there fired it up to finish cleaning the injectors out it runs like a top! Drove it up and down the road everything works on it perfect.!

Re: Turbos????
Saturday, April 22, 2017 7:54 AM
I hope to be driving mine soon. My daughter's Firebird has been sucking up most of my free time.




Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search