1987 Buick Skyhawk Wagon, Vin K: Suddenly won't start, radiator fan turns on when key in ON position - Page 2 - First Generation Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Re: 1987 Buick Skyhawk Wagon, Vin K: Suddenly won't start, radiator fan turns on when key in ON position
Tuesday, June 05, 2018 3:09 PM
Orlen Brown wrote:

Yes these cars have been known to have ground issues. Old age promotes rust everywhere including ground connections. I remember last year when I was putting the Sunbird back together after a head job I forgot to connect the ground wire to a head bolt near the coil. I had all kinds of crazy symptoms that set me back almost a week scratching my head because nothing was related. One of the symptoms was that one of the idiot lights ( it think it was the alt ) would stay lit the minute you connected the battery up and stayed lit even without the key in the ignition! Making the matters worse I had managed to bury that connector underneath the intake and didn't even see it. Only when I looked back at some "before" photos did I remember seeing it there. So I'd bet you are experiencing a similar situation.

Be patient and you will eventually figure this out.

.


Guessing again it's a bad ground... but where?

I started it up this morning, and it fired right up for about 3 minutes... to which it suddenly turned off and began it's Spin the Radiator fan thing it was doing before.

Guess I'll check near the ECM first, and go from there?

Any tips for checking grounds?

Re: 1987 Buick Skyhawk Wagon, Vin K: Suddenly won't start, radiator fan turns on when key in ON position
Friday, June 08, 2018 9:51 PM
Grounds for the ECM are on the bellhousing bolts and head studs.
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search