2.2 Engine Issues.... HELP - Second Generation Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
2.2 Engine Issues.... HELP
Friday, April 15, 2005 7:25 PM
I have a 1993 2.2 litre engine... 150 K miles on it - Automatic transmission.

First, like last week, the car was idling real funny.. for about a day... it jump from 800 - 1200 RPM back and forth, misfire like hell, and sound nasty. Occasionally it fall to 300 - 800 RPM and a check engine light would come on(damn ODB-I the light wouldnt stay on long enough to plug the scanner in)... however as soon as i passed 1500 RPM it be fine... i was told to replace my Idle Control Sensor, however the problem stopped before i could (it only lasted for less than 1 day).... today, my car started rumbling. I have extreme power loss accelerating, however the RPMS climb normally, the exhuast sounds like there is a hole in it, however there is not. My friend told me i probably jumped time... i think it may be my ignition and it fouled the plugs (i changed the plugs and wires last month) because something simular happened 2 years ago when the car fouled the ignition... however at that time i didnt pay attention to the tach then to see if the RPMs climbed normally.

Does anyone have more insite on this? I Do plan to take it to a mechanic shop to get it computer tested to see exactly what it is, but i'd like to know a little about what im dealing with, before i take it in to get it tested...

thanx




Re: 2.2 Engine Issues.... HELP
Saturday, April 16, 2005 1:36 PM
check the IAC pintle - they get gummed up with carbon and cause bad idle problems also can cause you to run rich/lean
Re: 2.2 Engine Issues.... HELP
Saturday, April 16, 2005 3:41 PM
Possible ignition module or coil pack problem? They really sound like crap when they lose a cylinder.

BTW, any time the CEL comes on, the code is stored in the computer for reference. No need to *catch* it with the light on.



JLP
01' 5 speed Z <--- 03' 15.2 @ 90
79' Blue Monte <--- 03' 12.18 @ 110.86
Re: 2.2 Engine Issues.... HELP
Saturday, April 16, 2005 5:06 PM
SeriouZ wrote:

Possible ignition module or coil pack problem? They really sound like crap when they lose a cylinder.

BTW, any time the CEL comes on, the code is stored in the computer for reference. No need to *catch* it with the light on.

Ended up being a coil pack.... number 1 cyl not firing.... 15 minutes, $45 and a case of beer later and my car is running smoothly... hehehe



Re: 2.2 Engine Issues.... HELP
Saturday, April 16, 2005 7:05 PM
i have this problem...

it sounds like a riding lawn mower and smells like a gasstation. 2 pistons aren't firing due to coils...

but im selling it so @!#$ it. it's been sitting since it happened.




...

Re: 2.2 Engine Issues.... HELP
Saturday, April 16, 2005 8:18 PM
SunValier wrote:

i have this problem...

it sounds like a riding lawn mower and smells like a gasstation. 2 pistons aren't firing due to coils...

but im selling it so @!#$ it. it's been sitting since it happened.


Well its an easy fix... $45 for an AC Delco Coil pack, $20 for like a cheap off brand @ advance autoparts...

go to v6z24.com and check out the repair forum ... that should give u instructions on replacement.. it only took me 15 minutes

and for the gas-station smell... get u a cup the size of like a cup on a niquil bottle... fill with karosene, put half in your gas tank, the other in your oil.. it'll clean it all out for ya

All those fuel system cleaners with "Jet Fuel added" ... all they do is add karosene...

---------------------
Xstreme - W----I----D----E--------B----O----D----Y - Second Gen Cavalier



Re: 2.2 Engine Issues.... HELP
Saturday, April 16, 2005 9:16 PM
yea... but its only firing 2 cyl. gas is just draining out the back i love it, 'cause if u get it to backfire good enough flames....

friend of mine seen it and got off my bumper when it started to happen. lol.


...

Re: 2.2 Engine Issues.... HELP
Sunday, April 17, 2005 5:14 AM
SunValier wrote:

yea... but its only firing 2 cyl. gas is just draining out the back i love it, 'cause if u get it to backfire good enough flames....

friend of mine seen it and got off my bumper when it started to happen. lol.

I'd be like ... damn... that looks cool... but DAMMMMMMN i just paid 2 dollars and 6 cents a gallon for that gas....



Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search