The Gravana Coilover Thread (Troubleshooting, etc) - Page 5 - Suspension and Brake Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Re: The Gravana Coilover Thread (Troubleshooting,
Friday, February 24, 2006 2:33 PM
my rears i took all the preload off , and it seamed to ride better

the front ive still got preloaded , but im gonna be changing that prob this weekend , and see if that smooths it out some

mine rides good tell you hit some bad road , or a step in the road , but its done that even before the gravana coil overs , it should like im not riding on rubber , and ive got new stuff in the rest of the front end

and i didnt think the azenis sports side walls were that stiff , lol








Re: The Gravana Coilover Thread (Troubleshooting,
Friday, February 24, 2006 3:15 PM
Yeah I took all the preload out of mine to see how they would ride after they got a little wear on it. Mine is the same way though, just kindly stiff on bad roads, but thats to be expected.



Proud member of JBOK (J-bodies of Kentucky)



Re: The Gravana Coilover Thread (Troubleshooting,
Friday, February 24, 2006 4:55 PM
the directions a couple of you guys have where did you get them form??? should i e-mail Jim about it????





Re: The Gravana Coilover Thread (Troubleshooting,
Friday, February 24, 2006 6:24 PM
97cavy22 wrote:

the directions a couple of you guys have where did you get them form??? should i e-mail Jim about it????


the only directions that i got are posted on the first page of this thread. i had to email jim in order to get them. its basically just a diagram that shows what pieces go where in order to get everything to fit together with the mount. after that, install is a breeze





Re: The Gravana Coilover Thread (Troubleshooting,
Friday, March 03, 2006 2:56 PM
Ok... so I am riding on all 4 corners with these coilovers now... I have had the fronts on for a week with no problems (apr. 600 miles) Rears just got installed last night (they have around 100 miles on them between last night and running around today)

So with just the fronts on... I had ride height and quality were I wanted it... 'cept for one side being just a smidge higher than the other. I am sitting with about a finger width in the front.

With the rears on, I def. have some test n' tune to do. - I barely preloaded the springs, have hardly any bounce, but the rear is a bit higher than I want.

So what do you guys have the valving set at? Right now I am at 4 in the front, and 6 in the rear, and the rear still seems stiff... should I back it down more, or give the rear some time to settle?

Good news- tires and rims are sitting at the post office waiting for me to pick them up, and I go tomorrow to get the car aligned, after I even out the front, and drop the rear about 3/4 inch.
Re: The Gravana Coilover Thread (Troubleshooting,
Friday, March 03, 2006 3:09 PM
to be honest i forget where my settings are , i think im around 9 in the front , and the back ive got no idea

lol

its been that long since ive messed with them







Re: The Gravana Coilover Thread (Troubleshooting,
Friday, March 03, 2006 3:59 PM
I have mine set at 8 in the front and 9 in the rear.



Proud member of JBOK (J-bodies of Kentucky)



Re: The Gravana Coilover Thread (Troubleshooting,
Friday, March 03, 2006 4:02 PM
i think i have mine set at 9 in the front and maybe 10 in the back





Re: The Gravana Coilover Thread (Troubleshooting,
Friday, March 03, 2006 4:34 PM
im at 4 all around. it took mine about 2-3 weeks to finally start settling



Re: The Gravana Coilover Thread (Troubleshooting,
Saturday, March 04, 2006 8:44 AM
alias1429 wrote:

97cavy22 wrote:

the directions a couple of you guys have where did you get them form??? should i e-mail Jim about it????


the only directions that i got are posted on the first page of this thread. i had to email jim in order to get them. its basically just a diagram that shows what pieces go where in order to get everything to fit together with the mount. after that, install is a breeze


thanks i appreciate it

shouldn't be long, maybe another week or two before i get some warmer weather and time to put these things on



Re: The Gravana Coilover Thread (Troubleshooting,
Tuesday, March 07, 2006 1:29 PM
Welp guys... it's been a total of 4.5 weeks riding with these coilovers, and after much debating with myself, I am back to a stock suspension.
For multiple reasons -
one, these things are just to much for me to deal with, to many settings, to many adjustments that I just don't care about.
two, I can't seem to get these dialed in the way I expected to, and don't have the time to play with them.
three, The roads around here just don't seem to lend themselves to a slammed car, and these suckers are just plain to stiff for the roads.
four, there seems to be absolutly no support from Gravana on these things, and quite frankly, Jim appears to have dropped these things and ran.


So... if anyone wants a coilover system, check out the classifieds.

On that note - I really like the lowered look, but want a close to stock ride - any suggestions?

Re: The Gravana Coilover Thread (Troubleshooting,
Wednesday, March 08, 2006 6:36 AM
The Chosen One wrote:


On that note - I really like the lowered look, but want a close to stock ride - any suggestions?


try the pro kit with agxs. i just installed a set of those on my roommates z24 and they ride really well. i almost wish i would have went that route instead of buying my gravanas





Re: The Gravana Coilover Thread (Troubleshooting,
Wednesday, March 29, 2006 4:05 PM
well im finally going to put these on tommrow, hopefully it goes well

im gonna try not preloading the rears, and maybe a tad in the front since it seems most of you have taken it all out.

any other little tidbits on adjusting that you guys have figured out after driving on them for a few months that could help me??



Re: The Gravana Coilover Thread (Troubleshooting,
Wednesday, March 29, 2006 7:16 PM
i would ride with them at 7 to start with, thats what i did. Gives you an idea of stiffness. i then bacjkem them down to 4 where it was confortable for dd. im getting some nice rubber pinching in the front left though. kinda worries me but i dotn know hwo to fix it. God i wish i had gotten the teins. these are nice but not worth the hassle




Re: The Gravana Coilover Thread (Troubleshooting,
Monday, April 03, 2006 3:06 PM
well they don't work with my 05 mounts, so i guess i gotta get the older style correct??

i went to a chevy dealership and looked at front mounts from a 97, seems like it would work perfect once u followed those directions posted earlier in this.

where is the cheapest place to get some mounts? id rather go new instead of used ones, i already have a used pair acctually on my 97 daily driver cav, but with almost 90thou miles id rather not use them on a car that's not even a year old. And as far as i know the rear's are the same from 95-05 so i shouldnt have a problem with those correct?



Re: The Gravana Coilover Thread (Troubleshooting,
Monday, April 03, 2006 3:44 PM
why wont they work on your 05 mounts ??


there is nothing special that needs to get done


but if you have the nuts with the spacers , as 1 piece then you will need a spacer that thickness or a stack of washers


that is the only difference that i know of


i know my 00 cav has seperate spacers and so does my g/fs 02 cav







Re: The Gravana Coilover Thread (Troubleshooting,
Tuesday, April 04, 2006 7:16 PM
the top gold piece of the gravana strut doesnt hit any metal on the mounts, if i put it on it's gonna push into that middle rubber piece and eventually screw the mount all up from having the whole weight of the car riding on it (i wish i would of got pics)....from what i see by looking at the older style mounts, when you take it apart the whole top portion of that strut sits up in the mount and it looks like it would work fine. From what the dealer told me the rears should be the same from 95-05, so i only need fronts.



Re: The Gravana Coilover Thread (Troubleshooting,
Tuesday, April 04, 2006 11:40 PM
the center colar , or the outter colar ?


the center should locate in the cent of the hole


and the outter should locate inside the mount and sit on the metal in the strut mount








Re: The Gravana Coilover Thread (Troubleshooting,
Thursday, April 06, 2006 6:58 AM
ok these are the mounts i have in the front, are they the same things you had?



this middle piece is what the top gold part sits in, and it's gonna shove into that rubber that's in the middle there becaue it's not hitting any of the metal or something sturdy on the mount.





Re: The Gravana Coilover Thread (Troubleshooting,
Thursday, April 06, 2006 1:16 PM
yup that looks identical to mine


and the large outter gold part on mine sits flat inside there


and the inner gold sleve has a indentation that sits in the center hole


ill see if i can get some clear pics of mine , gimmie tell the weekend







Re: The Gravana Coilover Thread (Troubleshooting,
Thursday, April 06, 2006 7:33 PM
alright cool, i would really appreciate some pics, maybe i am doing something wrong, hopefully that way i wont have to spend the extra $$ for mounts.




Re: The Gravana Coilover Thread (Troubleshooting,
Friday, April 07, 2006 8:50 AM
nick gimmie your email , and ill send you the pics







Re: The Gravana Coilover Thread (Troubleshooting,
Friday, April 07, 2006 7:10 PM
yellow5spdcavy@aol.com

thanks again



Re: The Gravana Coilover Thread (Troubleshooting,
Friday, April 07, 2006 8:16 PM
i sent you 2 groups of pics


let me know if you got any questions







Re: The Gravana Coilover Thread (Troubleshooting,
Sunday, April 09, 2006 3:38 PM


thanks for the pics, when i put it on it looked exactly the way yours did, that is the problem im talking about. When you put weight on them doesnt that gold piece just shove up into that rubber piece and screw the mounts up? Do you still have em on your car? and has that been an issue at all?



Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search