Car Pulls to the left while Accellerating - Suspension and Brake Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Car Pulls to the left while Accellerating
Monday, June 16, 2008 10:27 AM
Ok I've been going through this crap for the past 2 seasons...

I found out this winter I had an effed up transmission mount insert so I lathed a new one and installed it.

Things I've checked / replaced:

- Front Brakes (Wilwood Upgrade)
- Rear Brakes (SSBC Upgrade)
- Front Wheel bearings (Torqued to 185 ft lbs spec)
- Car DOES need an alignment and shows visible toe-out
- 4 new Tires (was hoping it was radial pull)
- All 4 tires are at the same pressure
- Control arm bushings are fine
- Tie rods are fine because when the car pulls the wheel turns with it
- Car does not make any sounds or creaks while accellerating / decelrating or turning.
- Subframe bolts checked and tightened
- Steering rack bolts checked and tightened.
- Control arm bolts checked and tightened.


With all that said, whenever I put meduim to heavy throttle/load on the car the wheel turns about 15-20 degrees and the car immediately pulls left When I let off, the wheel goes straight and the car goes straight. I AM going to get an alignment this week but I fear this will not fix the issue.

Any suggestions anybody? I've checked everything I can and see nothing visually wrong.

Any help is truly appreciated I'm at the end of my rope.

-Chris-



-Sweetness-
-Turbocharged-
Slowly but surely may some day win this race...

Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 10:53 AM
torque steer LSD insert might help some?



http://members.cardomain.com/yellow05cavy
Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 11:20 AM
It sounds like torque steer to me also.



Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 11:23 AM
replace motor mounts.....sounds like torque steer.

take those junk brake upgrades off, and send them to me for proper disposal






Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 12:28 PM
An alignment was the first thing that came to my mind. You might be surprised how much difference it makes.




    Shop Manuals, Brochures:www.kenmcgeeautobooks.com
Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 12:53 PM
alignment is important, but I doubt it would cause a pull under acceleration only.



Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 4:13 PM
I have a fairly new RKSPORT lower mount and a TTR upper motor mount.

This isn't hard acceleration... this is the car pulling left as I just TOUCH the gas doing about 35 mph...

The car pulls to the left and the wheel turns. It never did this before when I was boosted it's something that's cropped up over the last 2 seasons.

It does it making zero boost. It's driving me nuts and it's really unsafe around turns on the highway doing 60+ mph as the car goes left and right as I barely touch the gas.

-Chris-



-Sweetness-
-Turbocharged-
Slowly but surely may some day win this race...
Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 4:21 PM
Check your axles. Or just replace them, only sounds logical to me.






Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 4:26 PM
HOLD on to the steering wheel when you drive and this wont happen lol.


I agree that it sounds liek torque steer



Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 5:19 PM
idk it sounded like torque steer at first but now that you say it does it under no boost then it doesnt sound like torque steer.



http://members.cardomain.com/yellow05cavy
Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 5:54 PM
still i think its torqu steer, any fwd car with decent power gets it, my unboosted car will when i get on it



All show, coming soon ---> GO

Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 6:28 PM
That's the thing and that's my point.

I'm NOT getting on it.

2% throttle at 35 mph yeilds a lane-change for me. The wheel turns 20 degrees. Thats far from normal and my car stock and turbo'd 3 years ago NEVER did that.

-Chris-



-Sweetness-
-Turbocharged-
Slowly but surely may some day win this race...
Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 6:42 PM
What did you change on the car before it started doing it?



Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 7:00 PM
when was your last alignment?



All show, coming soon ---> GO
Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 7:58 PM
well you said you know the alignment is off... common sense should tell you to fix the known problem first..

from what your describing I would guess a trans mount or a control arm bushing



Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 8:49 PM
Darkstars wrote:

control arm bushing


FTW

it's happened to me twice. make sure the control arm bolts are in very tight. Specifically, the ones towards the front of the car.




Desert Tuners

“When you come across a big kettle of crazy, it’s best not to stir it.”


Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 8:57 PM
I will re-check those horizontal control arm bolts one last time. As stated earlier ALL subframe/control arm bolts have been checked and tightened.

Yes common sense dictates I fix the obvious issue first (alignment)... and as I have stated I am getting one in two days but I don't think it will fix the problem.

I got an alignment last year and it didn't fix it. Found out a trans mount was shot so I replaced it a few weeks ago. (car wasn't driven for 8-9 months) While it was off the road I did the tires since they were shot, wheel bearings since one wasn't so hot and brakes since the stock ones suck.

The car has only been on the road for 2 days, so I'll get it aligned this week. I'll check those bolts just before I go, though - to be 100% sure.

I'll let you guys know how it goes... I am not crossing my fingers though.

If anybody has any other ideas, let me know.

-Chris-


-Sweetness-
-Turbocharged-
Slowly but surely may some day win this race...
Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 9:39 PM
I'm not saying the control arm bolts, they can be tight and you can still have a bunch of play in the bushings



Re: Car Pulls to the left while Accellerating
Monday, June 16, 2008 10:17 PM
Yeah I've had it happen to me before and it was the control arm bushing.



Proud member of Jbody of Kentucky ... Click on sig to go!
Re: Car Pulls to the left while Accellerating
Tuesday, June 17, 2008 5:00 AM
Even on polyurethane bushings that are only about 2 seasons old and maybe 9000 miles?

-Chris-



-Sweetness-
-Turbocharged-
Slowly but surely may some day win this race...
Re: Car Pulls to the left while Accellerating
Tuesday, June 17, 2008 6:42 AM
take some pictures with many angles. it may not be a bolt, something may be bent like your swaybar, or you may have skipped a tiny bend on your inner tierod. i know my driver side had a bad one but i didn't see it till i removed the outter.

Do you hear any slight grinding or rubbing/vibrations when you make a right/left hand turn? Possible CV joint....but that is a really large stretch lol.



Re: Car Pulls to the left while Accellerating
Tuesday, June 17, 2008 9:29 AM
Darkstars wrote:

I'm not saying the control arm bolts, they can be tight and you can still have a bunch of play in the bushings


I know that bro. I was just stating that that's probably the "location" of the issue, not necessarily the JUST the bolts.


SweetnessGT wrote:

Even on polyurethane bushings that are only about 2 seasons old and maybe 9000 miles?

-Chris-


manufacturing defect maybe?



Desert Tuners

“When you come across a big kettle of crazy, it’s best not to stir it.”


Re: Car Pulls to the left while Accellerating
Tuesday, June 17, 2008 9:49 AM
i had this happen when i bought my first jbody a 2000 cavalier and it ended up being the rack and pinion was bad.... just a thought cuz it sounds identical to my prob and the rack fixed it



<a href="http://photobucket.com" target="_blank"><img src="http://i213.photobucket.com/albums/cc267/Turbocavy555/Misty1.jpg" border="0" alt="Photo Sharing and Video Hosting at Photobucket"></a>
Re: Car Pulls to the left while Accellerating
Tuesday, June 17, 2008 10:11 AM
Argh I'd hate for it to be a new rack... I've suspected that for a while myself but it's the last option.

I can get a new one and change it out fairly handily but... frick... lol.

I'll get the alignment done and have the car properly inspected. if absoloutely nothing is found wrong with the suspension / steering components it leaves me with not much else other than to change the rack, which I'll do in the fall when I pull the turbo and downpipe out. Might as well get new tie-rods at that point.

Thanks all for all your suggestions I do appreciate them. I'm hoping a combination of experiences from a few people will point me in the right direction as I'm almost out of options, and I'm sick of spending $$ lol.

-Chris-



-Sweetness-
-Turbocharged-
Slowly but surely may some day win this race...
Re: Car Pulls to the left while Accellerating
Tuesday, June 17, 2008 6:26 PM
This thought popped into my head today. You had problems with the power steering hoses, and this is a bit of a stretch, BUT...as you increase engine speed, the PS pump is pressurizing one side of the rack more than the other, causing it to pull left. Are there any steering issues at any other time, feels more boosted turning one way or the other? Could indeed be a bad seal inside the rack. I think I still have the one from the parts car...if needed.




14.330 @ 96.37mph
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search