a few aftermarket suspension questions - Suspension and Brake Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
a few aftermarket suspension questions
Wednesday, September 17, 2014 10:18 PM
Hey first off I've got a 99 cav I've been working on. Havn't been able to drive lately due to repairs and alot of time and money spent and it's getting very frustrating. Could use some input with my suspension setup. I've searched all the threads in this form but not clear and finding what I need. I have kyb agx with gc coilovers ( I kno not the best setup but too late now) with kyb mounts. K so my questions is. This the right order? From top down, nut, big flat washer, upper part of strut mount, thick washer under bottom of top mount, washer/race/washer, top hat then spring and bump stop. I don't have dust boot. 2nd question. If first question is correct, any idea why the rubber ring thing inside the top mount around the top nut looks mushroomed? Seems to turn ok. Never got rid of that 'popping' noise when replaced the mounts. Everything was replaced at the same time. Only driven 3 times since completed but here it sits again. One more question. The 'thick' nut... There suppose to be roughly 1/4 inch space all the way around where it sits on the mount?

ReD RaiN

pic 1
Thursday, September 18, 2014 12:00 PM
Heres a pic of the strut mount

ReD RaiN
Re: pic 1
Thursday, September 18, 2014 12:03 PM
Tim Marshall wrote:

Heres a pic of the strut mount
not sure why it didn't work. Lets try again..

ReD RaiN
Re: pic 1
Thursday, September 18, 2014 12:58 PM
Re: pic 1
Thursday, September 18, 2014 7:18 PM
thanks but i think that pic is a setup for factory or someone using lowering springs. i have coilovers.

ReD RaiN
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search