need help badly - Suspension and Brake Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
need help badly
Saturday, February 07, 2015 11:21 PM
T!M8!T Online
Hey so I have an ongoing brake issue I need ur help diagnosing. It's a 99 cav. There's a few problems im experiencing. Where to start.... First off, the abs light comes and goes. When front tires slide there's a clicking sound coming from driver side and brake pedal pulses slightly (only when clicking) not sure if this is normal. Never owned a vehicle with abs. Second issue.. Front passenger side caliper sticks after heated up. I tried pulling abs fuse and didn't make a diff. Also when passenger brake drags the rear brakes seem to tighten and stiffened brake pedal. I've never had no problems stopping the vehicle, doesn't pull but does shake alot when it sticks. I really need ur help. I cannot/won't take my car bk to a mechanic. Note calipers are new, steel brake lines been replaced. Fluid level normal, new brakes/pads shoes all around. Wheel bearings been done too. I have a set of flex lines waiting to get installed but I fear its abs related. No leaks. Any help would be appreciated. Don't have the money to keep spending in my j jus to make it work properly.


ReD RaiN

Re: need help badly
Saturday, February 07, 2015 11:24 PM
T!M8!T Online
Oh forgot to mention... These problems were here before I installed any new parts trying to fix it. I also cleared the codes from the computer. Didn't bring nothing up for abs


ReD RaiN
Re: need help badly
Sunday, February 08, 2015 4:27 AM
So with ABS disabled all of these problems still remain?

The clicking and pulse in the pedal sound like ABS is activating, but you tires should not be sliding. Disabling ABS should eliminate this problem.

If your caliper sticks, then it needs replaced, or rebuilt.



FU Tuning



Re: need help badly
Sunday, February 08, 2015 9:14 AM
T!M8!T Online
I kinda figured that's how abs acted but wasn't sure. As far as the clicking im not sure if that stops with the fuse pulled but yes the sticking brake still remains even with it out. After it cools the brake releases. caliper has been replaced twice already.. I read on google something bout 99's having bad abs problems like abs controller or module or something. But that should show as a bad code? Also read something bout a float that distributes pressure evenly to the wheels? Getting frustrated trying to figure this out


ReD RaiN
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search