The Dreaded ABS & Red Brake Light Fault Lights - Suspension and Brake Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
The Dreaded ABS & Red Brake Light Fault Lights
Monday, March 06, 2017 7:46 AM
My 99 Cavalier ABS has had this fault going for a year. I have tried to track it down but with no luck. I even had it at a dealer and they could not pin it down even with their Tech 2.

The symptoms are: If the vehicle sits for a day without running and is then started, the fault lights will be out and all will appear normal. As soon as a put the car in gear and then roll about 10-20 feet, I will hear a "crunchy" sound up under the hood on the drivers side (most likely the ABS pump motors moving) and then the lights will fault on. They then stay on throughout the driving cycle and will stay on for successive restarts unless the car gets at least a good 8 hours or so to sit.

While I had it at the dealer, I had the brake system completely flushed out and bleed out with fresh new brake fluid - it was overdue for that in the hopes that the Tech 2 motor assist bleed would exercise the motors and clear out any possible issue. After doing all of this the dealership still had the fault and indicated that the problem was with my ECBM located inside up under the dash near where the hood release latch is in the interior. So I swapped my ECBM box between my 1998 and my 1999 and waited a day to see if this was the case. I started up the 99 the next day and got the normal no light followed by the usual under the hood ABS pump sound and then the lights after I rolled the usual distance down my driveway. No joy there. This tells me it is not the ECBM.

Since this initially registers as normal but then activates the faults after motion, I am wondering if it is the indicator strobe ring on one of my CV joints. When I last inspected them when I check the sensors they appeared more or less normal and I brightened them up with a wire brush. I read about cracks sometimes in these in another older post and plan to check for them when the weather gets warmer but in the meantime am very interested in anyone else's thoughts from here - that is if it is not too much of a ghost town here as seems to be more and more the case these days.

thanks,

Brian

Re: The Dreaded ABS & Red Brake Light Fault Lights
Monday, August 28, 2017 9:56 AM
Did you successfully resolve this issue?
I have the same issue with my 1999 Sunfire GT.
Re: The Dreaded ABS & Red Brake Light Fault Lights
Tuesday, August 29, 2017 5:42 PM
I sure wish I did but nope, I still have the issue. I even had the dealer try swapping the entire master cylinder brake pump for another one in near new condition and they could not find the problem. Waste of time and $. When cold weather returns, it will no doubt take up where it left off in March and resume teasing me again by going out only to com back on after rolling a few feet and making that ABS pump motor "crucnchy" noise that it does. I may try a different dealer when I run into something that I cannot fix myself the next time. I have 2 spare master cylinder brake pump assemblies handy to try out. Other than this the car continues to run great.

Does your Sunfire play mind games and temporarily "recover" and have the lights go out when it is cold like mine does?

Brian
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search