2003 Cavalier Idle Problems.. HELP - Third Generation Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
2003 Cavalier Idle Problems.. HELP
Thursday, March 12, 2009 10:57 AM
A person on a local car site is having problems with her car and I am going to post below what she posted. I was wondering if anyone had any idea's what the problem could be. I asked her how many miles her car has however I have to guess she has well under 60K on the car.

Okay, so as some of you may know the story from before, some of you may not, here's a bit of a back story..

Back in early December, my car, virtually out of nowhere started idling pretty rough. The tach was jumping around between 500 and 1,000 rpms and the car was shaking pretty bad. Check engine light was on, etc. Took it to a place - they had it for a few days. They at first replaced the spark plugs. Problem not fixed. Then they replaced a fuel injector, insisting that it was definitely the problem - installed it, didn't help the problem - they took it back out. Then after a few days they decided it was the timing chain (yes, chain, I don't feel like having everyone go "you mean belt?" No. It's a chain) and that it must've skipped a tooth. Their bottom line was that it and the tensioner would need to be replaced, told me not to drive it for much longer without fixing it. Their estimate for that was $1200. Well, I had shelled out the $450 or so for the brake pads, rotors, oil, spark plugs, and labor and at the time, no other money to dish out. So I said, screw it, I'll drive it around until I can fix it. Then I lost my job.

So, I've been driving it around since December.. same problems, tach jumps, it idles rough. But nowwww, the car hasn't wanted to start about 4 times int the last 3 days, I've had to give it gas. Car almost stalled this past weekend when B turned the a/c on (I assume this is unrelated, though). When I drive, the "Trac Off" light randomly comes on, then randomly goes back off. When I go from a stop, my car lurches/jerks and it's pretty bad - feels like I'm about to stall (actually it feels like how it felt to try to go into first when I first learned stick hahaha), then with a little lead foot persuasion, it goes forward a little, then jerks really bad through second. Seems to be okay after that. Oh, and, it may be my imagination but I also feel like my car is going through gas too fast.

Cliff notes:
Car idles real rough
Shop tried new plugs, fuel injector - it didn't help
Diagnosed as timing chain skipped a tooth
Car jerks really bad going from a stop

So, I'm wondering.. what could this be? Even if you think it's far fetched, throw it out there! Because I'm clueless. I know I know nothing about cars at all - so I'd like to understand or get an idea of what could be wrong, hence my asking. Perhaps this is a dumb suggestion, but could something be wrong with my transmission?

Any, all suggestions would be great.


By the way, 03 Cavalier & it's auto trans.






2000 Buick Regal GSE - "Gods Grocery Getter is powered by an L67 3800" - 333WHP
12.900 @ 109.91mph 2.166 60Ft (Fastest 1/4)
13.374 @ 110.01mph 2.467 60Ft (Fastest Trap)

2004 Chevy Cavalier - 15.7 @ 90mph (Semi-Modded)

Re: 2003 Cavalier Idle Problems.. HELP
Thursday, March 12, 2009 11:13 AM
I found out her car has 85K on it.

Could it be the 02 sensor, ignition modular, or crank sensor causing this problem? I am wondering if its the 02 sensor is the cause?


2000 Buick Regal GSE - "Gods Grocery Getter is powered by an L67 3800" - 333WHP
12.900 @ 109.91mph 2.166 60Ft (Fastest 1/4)
13.374 @ 110.01mph 2.467 60Ft (Fastest Trap)

2004 Chevy Cavalier - 15.7 @ 90mph (Semi-Modded)
Re: 2003 Cavalier Idle Problems.. HELP
Thursday, March 12, 2009 1:15 PM
Could be ignition or fuel issue. On first guess I would say check fuel pressure and volume and go from there. I just posted something about a similar issue in another person's post in this forum. "01 Cavalier Please Help!!"



Re: 2003 Cavalier Idle Problems.. HELP
Thursday, March 12, 2009 1:20 PM
http://www.j-body.org/forums/read.php?f=30&i=49482&t=49482

It isn't exactly the same issue, but the same steps can be taken to find this problem. That is, if it isn't the timing chain issue.

As far as the A/C issue with the trac light, clueless. Sounds electrical




Re: 2003 Cavalier Idle Problems.. HELP
Thursday, March 12, 2009 1:50 PM
Check for a vacuum leak, they can cause all kinds of head aches.



Re: 2003 Cavalier Idle Problems.. HELP
Thursday, March 12, 2009 4:21 PM
2.2 or 2.4 ?


01 cav w/01 3400 gam gt 4t45e

Re: 2003 Cavalier Idle Problems.. HELP
Thursday, March 12, 2009 6:38 PM
Its sounds like a faulty Throttle Position Sensor




Re: 2003 Cavalier Idle Problems.. HELP
Thursday, March 12, 2009 9:49 PM
Jo Mx... wrote:

2.2 or 2.4 ?


2003-2005's only came with the eco.



Re: 2003 Cavalier Idle Problems.. HELP
Friday, March 13, 2009 6:37 AM
It is my fiances car.

The TPS sensor is working fine. From running it last night while a scan tool was hooked up I could see the TPS reading correctly. What is going on at idle is multiple misfires, mostly on cylinder 3, sometimes cylinder 4. Cylinder 3 had 20,000 something misfires stored, so now possibly thinking coils or valves.

Now just gotta find a spare coil pack to throw on it.



Re: 2003 Cavalier Idle Problems.. HELP
Friday, March 13, 2009 6:46 AM
I would look at replacing the ignition module. I've seen a few at my work come in with rough idle/misfire and that was the problem.




Re: 2003 Cavalier Idle Problems.. HELP
Friday, March 13, 2009 7:25 AM
I've been hearing that as well lately. I'm not too familiar with the Eco's, both my Cavs had LD9s.




Re: 2003 Cavalier Idle Problems.. HELP
Friday, March 13, 2009 10:26 AM
JuggaloZeke wrote:

I've been hearing that as well lately. I'm not too familiar with the Eco's, both my Cavs had LD9s.


I am not sure if the Ecotec has separate ignition coils? The Ecotec doesn't even have spark plug wires. It just has boots that connect that black panel that goes across the entire top of the valve cover (that says 2.2 Ecotec) to the spark plugs. Maybe one of those rubber boots is cracked?

I would remove that black cover on the top of the valve cover (4 bolts) and then you pull it up off the spark plugs and check to see if any of the boots are cracked. Maybe that is causing the misfire. Also I think you are suppose to gap the plugs at .43 so maybe the new spark plugs are not gapped right either?


2000 Buick Regal GSE - "Gods Grocery Getter is powered by an L67 3800" - 333WHP
12.900 @ 109.91mph 2.166 60Ft (Fastest 1/4)
13.374 @ 110.01mph 2.467 60Ft (Fastest Trap)

2004 Chevy Cavalier - 15.7 @ 90mph (Semi-Modded)
Re: 2003 Cavalier Idle Problems.. HELP
Friday, March 13, 2009 11:18 AM
I know how a coil pack works, thanks.



Re: 2003 Cavalier Idle Problems.. HELP
Friday, March 13, 2009 11:24 AM
JuggaloZeke wrote:

I know how a coil pack works, thanks.


I wasn't trying to say how a coil pack works. I was just trying to explain how the setup is on the ecotec being you say you are not two familiar.


2000 Buick Regal GSE - "Gods Grocery Getter is powered by an L67 3800" - 333WHP
12.900 @ 109.91mph 2.166 60Ft (Fastest 1/4)
13.374 @ 110.01mph 2.467 60Ft (Fastest Trap)

2004 Chevy Cavalier - 15.7 @ 90mph (Semi-Modded)
Re: 2003 Cavalier Idle Problems.. HELP
Friday, March 13, 2009 12:01 PM
I've seen my share of Ecos, just never dove into them. From what I've seen they are very similar to the LD9s.



Re: 2003 Cavalier Idle Problems.. HELP
Wednesday, March 18, 2009 12:58 PM
whatever shop she took it too should be shut down, because they should of checked for a fuel/spark problem before wanting the timing chain replaced.
Re: 2003 Cavalier Idle Problems.. HELP
Tuesday, March 08, 2011 4:48 PM
It probably is a bad IAC Valve , that stands for idle Air Control Vlave , reason i say this is my car had the same issue but my car would actually stall when i came up to a red light , the rpm's would jump from 1000 to 500 right to nothing and then stall , so anyways i bought a new IAC Valve installed it and now i do not have the problem also you can
get the part for 80 to 90 dollars brand new so i would try that out first before spending alot of money , let me know if it works out
Re: 2003 Cavalier Idle Problems.. HELP
Monday, March 14, 2011 11:23 AM
Sounds like a faulty IAC.






Re: 2003 Cavalier Idle Problems.. HELP
Tuesday, March 15, 2011 11:24 AM
Still happen with AC and Defrost turned off?



http://www.weatherallsautomotive.com http://www.planethax.com/j-body
Re: 2003 Cavalier Idle Problems.. HELP
Friday, March 18, 2011 11:24 PM
I had the same problem,after all the bull it was a vacuum problem.The map sensor had the hose under neith it unpluged.pluged the hose back in and car ran like it was a new car again.hope this helps.let me if it does.
Re: 2003 Cavalier Idle Problems.. HELP
Tuesday, March 22, 2011 9:30 AM

Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search