2.2 idles fine, but dives with gas applied? - Third Generation Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
2.2 idles fine, but dives with gas applied?
Thursday, May 22, 2014 2:10 PM
Hi everyone,

My 2000 Cavi just started doing this, I didn't think I was going to get it home.

2000~ 2.2, 5 speed.

The car idles smooth, around 900 RPM. But coming home today it stalled several times when leaving from a stop, in first gear. This has never happened. As it idles normally, if a tap the gas, the engine bogs down. And then the last time it stalled, I couldn't get the RPMs high enough to even take off. I am working with a clutch, I was stranded in the road for about one minute, I was trying to rev the engine up, it would not go above like 1400 RPM. I sat there for a minute trying to rev, then it just shot up normally as I gave it gas, I then took off and got home.

If you've ever had a car run out of gas, this is kind of how it was acting, sputtering.

The gas level is good, and no engine lights were on. I suppose some bad gas could cause this, I do run 1 bottle of dry gas through the tank every winter to remove water.

Any ideas? Thanks in advance....




Ipud wrote:

We put Jap Traps on cinder blocks around here. We don't wave the American flag for novelty


I proudly own American cars, nothing else....




Re: 2.2 idles fine, but dives with gas applied?
Thursday, May 22, 2014 2:31 PM
Sounds like maybe tps related. Do you have a multi meter? The tps should have 4.5-5v at one pin, when you cycle the throttle another pin should increase In voltage as you open the throttle. The third is ground.

I forget which is which. The test should be administered with key on engine off.

That's where I would start. Without tps our cars don't know how to fuel.


"A car just isn't a car without a little blood, sweat, and beers." -- Shadowfire
Re: 2.2 idles fine, but dives with gas applied?
Thursday, May 22, 2014 8:20 PM
TPS or fuel pump
Re: 2.2 idles fine, but dives with gas applied?
Friday, May 23, 2014 6:41 AM
TPS or MAP. Either one will cause the engine to be late advancing timing and increasing fuel, so the quick dump of air causes it to bog.





Re: 2.2 idles fine, but dives with gas applied?
Monday, May 26, 2014 4:25 PM
Thanks guys. I'm going to try to isolate which it is....




Ipud wrote:

We put Jap Traps on cinder blocks around here. We don't wave the American flag for novelty


I proudly own American cars, nothing else....



Re: 2.2 idles fine, but dives with gas applied?
Friday, May 30, 2014 3:17 PM
Well, the verdict is in.....IT WENT AWAY! Lol I've driven the Cavi all week, around 400 miles, it it has not once bogged or stalled taking off in first gear. I have no clue why. I did run another bottle of gas dry through one tank, and the next tank I added Gumout fuel injector cleaner.

Maybe when it originally was bogging last week it had some bad gas or water in the gas? Dunno, just glad it stopped



Ipud wrote:

We put Jap Traps on cinder blocks around here. We don't wave the American flag for novelty


I proudly own American cars, nothing else....



Re: 2.2 idles fine, but dives with gas applied?
Saturday, May 31, 2014 6:54 AM
My old gmc truck routinely runs horrible then fixes itself with no help from me after a few miles. Some vehicles just like to give back. Lol.




"A car just isn't a car without a little blood, sweat, and beers." -- Shadowfire
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search