can the computer detect a motor swap in a 99 cavi? - Third Generation Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
can the computer detect a motor swap in a 99 cavi?
Wednesday, June 25, 2014 11:41 PM
I just put a ld9 in my cavi it had a ld9 but now when it is running at idle runs perfect but if I try and hit the gas it feels like it is going into
a limp mode,gm says it can detect a motor swap in all my years of doing motors(older cars)I have never seen where the car will go into a limp mode.
I could see this on newer cars but I have never seen this on older cars.
the problem im having is like I said if I drive the car and slowly press the gas it will go all the way to the redline
but if I hit the gas (try and pass a car it sounds like it has a really bad miss..

Re: can the computer detect a motor swap in a 99 cavi?
Thursday, June 26, 2014 3:55 AM
Something is wrong.

Our PCMs are incapable of telling if the engine was swapped. Literally 100,000 of these engines have been swapped...






Re: can the computer detect a motor swap in a 99 cavi?
Thursday, June 26, 2014 5:00 AM
-MD- Enforcer wrote:

Something is wrong.

Our PCMs are incapable of telling if the engine was swapped. Literally 100,000 of these engines have been swapped...

This. You have a mechanical issue somewhere. Do you have a spare throttle positioning sensor to try?



"In Oldskool we trust"
Re: can the computer detect a motor swap in a 99 cavi?
Thursday, June 26, 2014 5:08 AM
If it idles fine, it's sounding like a TPS issue to me.



I'm cleaning out my garage!
Billet upper mount for 3rd gen V6 swap!


Re: can the computer detect a motor swap in a 99 cavi?
Monday, July 07, 2014 1:35 PM
Our cars do not have a limp mode.

Sounding like a TPS issue also.

Does it have a CEL?



FU Tuning



Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search