Ignition Coil/Housing Problem - 3 times in a row - Third Generation Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Ignition Coil/Housing Problem - 3 times in a row
Tuesday, August 06, 2013 4:37 PM
1999 Cavalier w/2.4
- Got a random misfire code, kind of figured problem with a coil, rubbers, or plastic housing. I have 2 other complete assemblies I knew worked fine, so I swapped 2nd unit in, and I was up and running just fine, until about a week later....
- SAME damn thing.
- This time I figured I had a bad plug and it was somehow burning out a coil, so I put in new plugs and swapped in my last complete assembly. Up and running just fine, until about a week later...
- and again it did it.
- Parked it and have not looked at it yet. 3 problems in a row? Something is causing this - beyond coincidence.
I plan to connect the unit up with ignition wires and use my timing gun to verify the problem... but I suspect the problem is either the coil or coil housing,,,, but 3 in a row seems just a little too strange.
Anyone have any ideas?

Re: Ignition Coil/Housing Problem - 3 times in a row
Wednesday, August 07, 2013 8:12 AM
By housing do you mean ignition control module it may be this if you have not replaced it but a week after you change each would be wierd..... id also make sure you have no lose wires on the coil.... new ones for some reason tend not to stick the best


Erik Packard
Re: Ignition Coil/Housing Problem - 3 times in a row
Wednesday, August 07, 2013 10:55 AM
2200 coil swap already, that will fix your problem


FuzzMASTA9
Re: Ignition Coil/Housing Problem - 3 times in a row
Friday, August 09, 2013 8:25 AM
Full housing means: the base aluminum plate upon which everything is mounted: igntion module, coils, plastic coil housing. I have 3 of them.....
I'll be doing some checking tonight. Something strange is going on here.
Re: Ignition Coil/Housing Problem - 3 times in a row
Friday, August 09, 2013 1:45 PM
All that fiddling with the housings and you haven't bothered to check/change the ICM bolted to the underside of the IDI cover?

Tsk tsk...

-Chris-



-Sweetness-
-Turbocharged-
Slowly but surely may some day win this race...
Re: Ignition Coil/Housing Problem - 3 times in a row
Saturday, August 10, 2013 9:23 AM
Pete P wrote:

2200 coil swap already, that will fix your problem


This ^ and it's way easy to do if you get ICM, Coil packs, wires and wire harness from 98+ 2200 SFO OHV Cavy.
Re: Ignition Coil/Housing Problem - 3 times in a row
Saturday, August 09, 2014 12:43 PM
Make sure all the rubber washers and spacers are used when installing the cover plate. If the washers and spacers are not used it can cause the cover plate to twist and apply pressure on the ignition housing causing it to crack.
Re: Ignition Coil/Housing Problem - 3 times in a row
Friday, August 15, 2014 1:43 PM
i had a bad coil on my 2.4. swapped it with an extra one i had. that lasted a few months, then it would misfire under load. do the 2.2 coil&icm swap and you will not be disappointed.



"If I'm not back in 5 minutes...just wait longer"
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search