Mileage will NOT light up on 2003 cavalier cluster?? - Audio & Electronics Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Mileage will NOT light up on 2003 cavalier cluster??
Saturday, August 07, 2010 6:18 PM
Was just going to install a sunfire cluster into my cavalier, i plugged it in everything works but the mileage is sooo dim you cannot see it at all. If you really look you can see it. I tried all fuses already and dimmer switch , i cannot get it to light up. i thought for sure it was my new cluster, so i plug the old one back in and it will not light up either? Hopefully someone can help asap while its all apart

Re: Mileage will NOT light up on 2003 cavalier cluster??
Saturday, August 07, 2010 8:41 PM
If you give your dash above the cluster a good hit, it will light back up...This is a common problem among the newer clusters, its a bulb that gets sorta loose and very hard to fix due to the fact its very hard to take apart the newer clusters.





Re: Mileage will NOT light up on 2003 cavalier cluster??
Sunday, August 08, 2010 8:45 AM
my black cat cluster needs new led's i think, it does not display mileage and the left side intermittently lights up. i may have them re engineer it with red needles this time.



Re: Mileage will NOT light up on 2003 cavalier cluster??
Thursday, August 12, 2010 6:48 PM
yeah tht happen in my girls cav after i put the dash back together and in my dads cav wen he got it back from the people who installed his stereo we jus gave it a good smack or two and it lit right back up.
Re: Mileage will NOT light up on 2003 cavalier cluster??
Thursday, August 19, 2010 9:56 AM
silver03cavii wrote:

If you give your dash above the cluster a good hit, it will light back up...This is a common problem among the newer clusters, its a bulb that gets sorta loose and very hard to fix due to the fact its very hard to take apart the newer clusters.



yea just give her a good hit like the fonz


Ayyyyyyyy








Re: Mileage will NOT light up on 2003 cavalier cluster??
Thursday, August 19, 2010 10:07 AM
I just beat mine like it owes me money.



Re: Mileage will NOT light up on 2003 cavalier cluster??
Friday, August 20, 2010 12:35 AM
all joking aside, i went outside to start my 05 sunfire and it was right after posting up the fonz and to my surprise my millage didnt light up, no @!#$, so i actually go wow wtf and hit the dash and yup it worked lol









Re: Mileage will NOT light up on 2003 cavalier cluster??
Friday, August 20, 2010 12:35 PM
Mine lights up but it just displays all kinds of crazy digits. I think its trying to tell me something.......



Re: Mileage will NOT light up on 2003 cavalier cluster??
Friday, August 20, 2010 12:48 PM
TheSundownFire (GME Chat) wrote:

Mine lights up but it just displays all kinds of crazy digits. I think its trying to tell me something.......


thats what mine does. if you push on the area where it should read it still tells u what its supposed to say...lol



Re: Mileage will NOT light up on 2003 cavalier cluster??
Friday, September 03, 2010 2:36 AM
EvoFire wrote:

TheSundownFire (GME Chat) wrote:

Mine lights up but it just displays all kinds of crazy digits. I think its trying to tell me something.......


thats what mine does. if you push on the area where it should read it still tells u what its supposed to say...lol



HHahahahaha My 00 Z lights up, but says the weird digits too. So If i need the mileage, I do that push thing. If I bang on it, it works for about 20 seconds or till the next bump, and goes back lol. Oh well. Lol




Re: Mileage will NOT light up on 2003 cavalier cluster??
Friday, September 03, 2010 11:35 AM
Mike Z A.K.A SNEEZY wrote:

EvoFire wrote:

TheSundownFire (GME Chat) wrote:

Mine lights up but it just displays all kinds of crazy digits. I think its trying to tell me something.......


thats what mine does. if you push on the area where it should read it still tells u what its supposed to say...lol



HHahahahaha My 00 Z lights up, but says the weird digits too. So If i need the mileage, I do that push thing. If I bang on it, it works for about 20 seconds or till the next bump, and goes back lol. Oh well. Lol


here too




Re: Mileage will NOT light up on 2003 cavalier cluster??
Monday, September 20, 2010 6:15 PM
I have a '05 cav. and the mileage back lit bulb die and the bulb behind the temp gauge go out also. I replaced the with Radio Shack pn 272-1154 12v 50mA bi-pin lamp bulbs. They are smaller than original ones but work. Also can be used in the factory radio. Cluster is easy to disassemble. Front and back covers come off after releasing tabs around the edge. Use tape and mark tip positions on all needles because you must pull them off. Unsolder bulbs from circuit board. Must do this first for mileage back light. Them squeeze white tabs on the frame around lcd screen and GENTLY bend the assembly away from printed circuit board ONLY far enought for bulb to come out. Then put new bulb in and through the holes in the board and solder fast and GENTLY put lcd screen assembly back in place. Unsolder any other bulbs and replace. Now you will have lights again and only sent $1.70 per bulb and not $100+ for someone to reman it or a new one. The factory radio is even easier. take top and bottom plates off radio, they pop off the pressed tabs. CAREFULLY disconnect the three wire connectors one on one side and two on the other can't remember which one is top and bottom, but you will see. They unplug from inside the radio NOT from face plate circuit board. Pull all knobs straight off posts and release plastic retaining tabs around face plate to remove it. You can unsolder the bulbs from back side of circuit board without unbolting it from plastic faceplate. Don't let any one tell you can't diassemble the cluster and bulbs can't be replaced. I fixed mine and everything lights up perfectly and only cost me $6.00, an hour of my time and a little solder to fix. It can be done, just take your time if not careful you might be buying a new cluster. Good luck.
Re: Mileage will NOT light up on 2003 cavalier cluster??
Friday, September 24, 2010 1:27 AM
David Meiser wrote:

Don't let any one tell you can't diassemble the cluster and bulbs can't be replaced. I fixed mine and everything lights up perfectly and only cost me $6.00, an hour of my time and a little solder to fix. It can be done, just take your time if not careful you might be buying a new cluster. Good luck.


Dude, you got lucky.. I've taken apart 12 or so of them now, and only one of them ever went back together and had all four needles still work.

I won't tell anyone you can't do it... but it's frickin' hard.



Re: Mileage will NOT light up on 2003 cavalier cluster??
Friday, September 24, 2010 1:45 AM
John Lenko wrote:

David Meiser wrote:

Don't let any one tell you can't diassemble the cluster and bulbs can't be replaced. I fixed mine and everything lights up perfectly and only cost me $6.00, an hour of my time and a little solder to fix. It can be done, just take your time if not careful you might be buying a new cluster. Good luck.


Dude, you got lucky.. I've taken apart 12 or so of them now, and only one of them ever went back together and had all four needles still work.

I won't tell anyone you can't do it... but it's frickin' hard.



This....



And I still Wont try it lol




Re: Mileage will NOT light up on 2003 cavalier cluster??
Saturday, September 25, 2010 11:42 AM
First off you must mark where the needles where they rest when unplugged. Second the needle assembly electrics are very delicate, this is not like wrenching on an engine. No disrespect but I can understand why and how people can make a good living remaning them.
Re: Mileage will NOT light up on 2003 cavalier cluster??
Saturday, September 25, 2010 2:06 PM
I'm guessing you managed to get all four needle caps off the drive pin without pulling the pin out of the gear pack. That's the problem with most of the 2000+ clusters.. once you pull a single pin out, it's fooked!



Re: Mileage will NOT light up on 2003 cavalier cluster??
Saturday, September 25, 2010 4:07 PM
I have the same problem and by the sound of it, I will need to pay $200 if I want to see my odometer clearly again? Great. I will just have to stick to shining a flashlight at it to read the mileage easier (2nd pic). haha


Re: Mileage will NOT light up on 2003 cavalier cluster??
Sunday, September 26, 2010 10:56 AM
If you're buying a brand new cluster from the dealer.. yeah, you'll probably be paying $200 or more. But I've had no problems getting a $20 cluster from the wrecking yard and replacing it myself... so..

Assuming the "smack the top of the dash" trick no longer works..



Re: Mileage will NOT light up on 2003 cavalier cluster??
Monday, September 27, 2010 11:06 PM
after reading this i went out and hit my dash a few times and mine still doesn't work, most likely end up buying a black cat cluster just for that reason lol



http://www.cardomain.com/ride/3877823
Re: Mileage will NOT light up on 2003 cavalier cluster??
Thursday, September 30, 2010 10:10 AM
TheSundownFire (GME Chat) wrote:

I just beat mine like it owes me money.


Chances are that it does, its a J!

This issue happened to my '01, giving it a good smack usually did the trick.




Re: Mileage will NOT light up on 2003 cavalier cluster??
Monday, October 04, 2010 2:47 PM
I had the problem of crazy digits as well. If I pushed on the cluster, it would show the correct miles. I took the dash apart, and found that the connector that hooks up to the back of the cluster was a little loose. If I wiggled it around, or pushed it into the connector it worked perfectly. Might want to experiment with the different kinds of pressure, then just use duct tape or something to hold it in that spot.




Re: Mileage will NOT light up on 2003 cavalier cluster??
Sunday, November 29, 2015 11:55 AM
Well, I tried to fix my 2003 Sunfire cluster. I found the needles were very hard to remove. Got all 4 off without breaking anything. Found the bad BULB for the odometer. Yes, it's a bulb and not a LED. Put it all back together, now all 4 stepper motors are hard to turn, won't work at all. I've read a lot of comments on how to do this properly, didn't work for me. Yes, I should have got the complete kit to replace the bulbs and stepper motors. I know for next time. So I went and got a used one.
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search