Knock....Knock - Page 2 - Boost Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Re: Knock....Knock
Monday, September 17, 2012 10:53 AM
No clue. It's better then what it was before. The belt didn't look bad though. Don't knows why it blew. Guess I was worse then I thoughT

Re: Knock....Knock
Monday, September 17, 2012 12:31 PM
You will figure out soon if this belt goes too. Just sayin.



Re: Knock....Knock
Monday, September 17, 2012 12:53 PM
You talking about the tensioner?

It's fine . Lots of pressure and smooth bearings in the pulley.

It went because I'm sure it hasn't been changed since it was first supercharged.
Re: Knock....Knock
Monday, September 17, 2012 1:02 PM
Ahh, ok. I see then it would not introduce knock.



Re: Knock....Knock
Monday, September 17, 2012 4:20 PM
Yah...I played with it when I was driving home and im defiantly seeing alot less knock on the interceptor.

No clue why but ill take it. All ive done is change the belt.

Still got to get my wideband hooked up so I can actually see whats going on with the motor though.
Re: Knock....Knock
Thursday, December 06, 2012 4:22 PM
To follow up on this...

NGK 3787 plugs installed

Wideband has been installed now and things are kind of making sense...Well not overly...lol


If I floor it from say 3000 rpm cruising in 3rd ill get knock...instant up to 7.9 or so. Wideband will drop to about 10.3-10.8 or so, so obviously quite rich.

Im assuming that the reflash is asking for to much timing at that instant thats causing this?

Now same scenario but I don't floor it, say I go 3/4 throttle and ill get knock as well but the wideband wont drop as much. It will stay in the 13.5-14.3 range until I floor it, which im assuming is to do with how GM has the pe mode set to (100% throttle)?

Now I do get a p0300 code randomly and it only seems to happen when the car is cold and in the rpm range of 2500-3000 rpm. No noticeable hesitation or any difference in driving it just sets the code.

Could this be involved with the way my afr's are going or is that how the reflash works?
Re: Knock....Knock
Thursday, December 06, 2012 4:48 PM
you could be getting knock from how rich it is, or timing. ?Hard to say for sure.



FU Tuning



Re: Knock....Knock
Thursday, December 06, 2012 4:49 PM
Would a video or my timing via interceptor help?

That way you can see rpm, timing and afr..

I just cant see GM making a tune that knocks like this all the time.
Re: Knock....Knock
Friday, December 07, 2012 4:36 PM
Philly D wrote:

Would a video or my timing via interceptor help?

That way you can see rpm, timing and afr..

I just cant see GM making a tune that knocks like this all the time.


That wont help me much. I would need to see real datalogs, and even then it is hard to say without being in the car and messing with stuff.



FU Tuning



Re: Knock....Knock
Friday, December 07, 2012 6:31 PM
Are you running poly mounts? False knock is always a possibility. The only crappy part about false knock is that youre assuming its happening. You really cant prove or disprove it. So if you assume its happening you have to live with it and hope nothing breaks.

The ECU only responds to the sensors input. So if the ECU thinks youre seeing a lot of knock it will pull timing and richen the AFR accordingly to help prevent a meltdown.

Thats all I have. Im not much of a tuner but Ive seen it happen before with L67s.





Re: Knock....Knock
Monday, July 01, 2013 9:26 AM
Problem 95% fixed.
It ended up being a bad fuel pump. It had the fuel pressure but not the flow that was needed.

Re: Knock....Knock
Monday, July 01, 2013 5:59 PM
Philly D wrote:

Problem 95% fixed.
It ended up being a bad fuel pump. It had the fuel pressure but not the flow that was needed.


doesnt make sense. How was your pump not giving enough flow, yet you were running extremely rich under WOT. If it did not have the flow it would have been lean.



FU Tuning



Re: Knock....Knock
Monday, July 01, 2013 6:30 PM
I think the problem lied in the part boost times.

Towards the end I was getting 12.2afr in second gear exactly like Luke C. Now I am at 10.8 in all gears. My base fuel pressure also bumped up to 56psi versus 52 it used to be.

I may be wrong as to why....but it worked.


I changed the pump and now my arf's are where most peoples are on the reflash and my knock is pretty much gone. I can run through the gears and get next to nothing. The only time I see any knock is if I floor it in say third or if im at cruising speed on the highway and get on it too hard.
Re: Knock....Knock
Monday, July 01, 2013 7:32 PM
These are exactly the same conditions I experienced with the reflash.



"In Oldskool we trust"
Re: Knock....Knock
Tuesday, July 09, 2013 5:55 PM
Odd thing ive noticed.... Meth your kind of right..

I can run first through 4th from a stop and not a touch of knock. But.......if I floor it in say second, third at even higher rpm's It jumps all the way up to 7.9* kr

My afr lately has been about 11.1 floored.
Re: Knock....Knock
Sunday, September 15, 2013 3:39 PM
Spark plug gap is where it's at I could not kill the knock using alky injection with 15 psi from a t67 gm which is a pretty large turbo and octane wouldn't do it for ,e it was the volume of the water fuel and alcohol in combustion chamber blowing out the sparke or at least making it hard to light off. I dropped gap to .024 and all is well, no knock and starts lighting up tires at 110 every time.
Re: Knock....Knock
Sunday, September 15, 2013 5:51 PM
My gap is right around .034 right now. Ill bring it down to .032 and see what happens
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search