blow off issue - Boost Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
blow off issue
Sunday, February 02, 2014 1:47 PM
Hello friends

I recently installed my new blow off but it is not opening causing turbo surge and the problem is because I Dont have the correct vacuum psi the gauge shows -10 psi.. I was told that i t should be Like at -20psi at idle ..

I decided to change all the vacuum lines and found a leak on the egr vacuum line that I'm taken care of but I don't know if I'm missing one..

I changed the one for the booster , map, fuel reg, one that goes inside the car that I don't really know where it ends.
I deleted the ac and the canister so they ones does not count..
Am I missing a line ?

What is the standard vacuum psi on our cars? I have a 96 ld9
Would some one please send me a diagram of the vacuum lines?

Thanks

Re: blow off issue
Sunday, February 02, 2014 2:33 PM
Your vacuum is fine. Vacuum is measured in inHg so -10psi is -20inhg. You are perfect. There is another issue not a vacuum issue.




On the inside my car looks like a fighter jet.
Re: blow off issue
Sunday, February 02, 2014 6:02 PM
Sounds like you might need a softer spring in it...



Re: blow off issue
Monday, February 03, 2014 3:49 AM
Does your boost gauge also have vac on it also?



FU Tuning



Re: blow off issue
Monday, February 03, 2014 5:37 AM
I'll just stop by to say that the vacuum line going through the firewall is for the cabin air mode control



"In Oldskool we trust"
Re: blow off issue
Monday, February 03, 2014 5:55 AM
Yes... It also reads vac.
Re: blow off issue
Monday, February 03, 2014 5:57 AM
If i deleted the a/c .. the line that goes inside the car through the firewall can i delete it ?
Re: blow off issue
Monday, February 03, 2014 6:08 AM
polloz24 wrote:

If i deleted the a/c .. the line that goes inside the car through the firewall can i delete it ?

It selects what vents the air comes out of, ie defrost, floor, bi-level, etc. Don't get rid of it. Even without AC you need to be able to defrost.



"In Oldskool we trust"
Re: blow off issue
Monday, February 03, 2014 6:14 AM
We dont have snow where im at jajaj we only have summer and winter here...

Ill just keep it and check if is cracked somewhere
Re: blow off issue
Monday, February 03, 2014 6:28 AM
Thanks guys!
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search