wTF happened! - Boost Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
wTF happened!
Sunday, February 23, 2014 7:28 PM
Ok, so, i was driving along 2nite and needed to merge over so i got on it some, around 9psi i guess. A puff of dark smoke came out from under the hood near the windshield, some even came in the cabin. Got off it super fast of course. The rest of the drive home was about 10-12 minutes. the car drove fine. temp stayed normal, zero noises. acceleration was normal.i stayed out of boost. so, wtf could have went wrong? Blown engine, head gasket..

Re: wTF happened!
Monday, February 24, 2014 6:08 PM
I went to check your profile to see what mods you had and nothing was there. Fill it out so people can help you out. What was your afr under boost and how is the car tuned? Did you check the oil to see if it is mixed with coolant? Did your engine light flash at you when this occured? How do the spark plugs look? Have you run a compression check?




Re: wTF happened!
Monday, February 24, 2014 6:17 PM
JUCNBST wrote:

I went to check your profile to see what mods you had and nothing was there. Fill it out so people can help you out. What was your afr under boost and how is the car tuned? Did you check the oil to see if it is mixed with coolant? Did your engine light flash at you when this occured? How do the spark plugs look? Have you run a compression check?

Yep that pretty much covers it.



"In Oldskool we trust"
Re: wTF happened!
Tuesday, February 25, 2014 1:52 PM
He got it figured out, it was a crack in the valve cover. it got oil on the manifold. everything you guys mentioned was checked and is good, so yeah. not nervous anymore!! Idk really about the tuning. my brother will have to explain that! Lol
Nikki..
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search