Slave Cylinder problems and fixes - Transmission Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Slave Cylinder problems and fixes
Saturday, May 26, 2012 7:35 AM
I am relativly new to the site, love it think its awsome and has made me more interested in my car and guys are doing to them.
That aside in my oppinion the j body slave cylinders suck huge!!!

about a year ago i did a full clutch kit, pressuer plate clutch and slave. had the flywheel machined

about 2-3 months later is was leaking.
replaced the slave under parts warentee

low and behold it leaks again 2-3 months later again
did some searching on here and found i should not have machined the flywheel.
so time #3, i bought a new slave and a flywheel,
found my old flywheel was about .040'' below speck so the new one went in

its been about 6 months now and i lost my clutch again slip my hand in the inspection hole in the trans and break fluid is present
i know its the lave again, theres no other hydraulic component in the trans.

i was using napa brand parts all listed repairs, im tired of it so i found the XTR STAGE 1 clutch kit,
its about the best i can find so im thinking of ordering it today,

i know other people are having the same issue iv heard it at the parts stores when i go and for shops iv called.
i am a mechanic by trade. and a diesel performance one at that. so i know its not lack of knowledge or xp of parts removal and instalation
what is the fix, hell what is the problem, every time the seal is pulled back ever so slightly on the release bearing.
are line pressuers known to be a little high and a check valve would allieviate the issue
is the master overpressurizing
im not the kind of guy to throw parts so lets get this figured

Re: Slave Cylinder problems and fixes
Saturday, May 26, 2012 7:36 AM
o and Thank you everyone for the input
Re: Slave Cylinder problems and fixes
Saturday, May 26, 2012 9:21 AM
There must be a bad run of aftermarket slave cylinders or something, it seems alot of people have been having problem's with them for the past couple of years or so. My flywheel has been machined and I have had no problems with my slave, but it is a factory GM unit I bought that came with my OEM
clutch set. Only thing I can figure.is the aftermarket slaves (which are all probably made in the same place) have an incorrect set of tolerances they are using while manufacturing.




Currently #4 in Ecotec Forced Induction horsepower ratings. 505.8 WHP 414WTQ!!!
Currently 6th quickest Ecotec on the .org -12.453 @ 116.45 MPH!!!

Re: Slave Cylinder problems and fixes
Tuesday, June 05, 2012 5:05 PM
i agree roofy
the rtx stage 3 kit should be here tomorrow so it will be in the car this weekend,
i will take a few pics and see if i can figure out how to post them.
it could verry well be the slaves are a bad batch, they all look the same, however the rtx seems to be beefier stainless braded lines in and out,
heres hoping
Re: Slave Cylinder problems and fixes
Tuesday, June 05, 2012 6:32 PM
Spec use to (not sure if they still do) use GM slaves in the kits they have. Never had a issue with a GM one.



FU Tuning



Re: Slave Cylinder problems and fixes
Sunday, January 13, 2013 8:47 AM
well its been a while since i have put the rtx clutch in my car ( tim ) and i have not had a problem with the slave cylinder at all so it seems ok however i now have a really really fast cluch, meaning i only have about 2 inches of useable cluch right at the top of travel, it dosent slip or sting so i know its fully actuated in gear but full release is 2 inches in. needless to say its a pain to drive due to grabbing so hard,
i have vacume bead it, gravity blead, pressure blead, its definatly ok but is there any way to give myself more finite control ??
Re: Slave Cylinder problems and fixes
Sunday, January 13, 2013 9:37 AM
Not to my knowledge. It's one of the big complaints with our cars.


"In Oldskool we trust"
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search