Clutch constantly needs bled. - Transmission Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Clutch constantly needs bled.
Thursday, December 06, 2012 2:32 PM
So I have a 97 sunfire and I am getting fed up with havin to bleed the clutch all the time. I have replaced the clutch, pressure plate, throw out bearing, and slave cylinder. Still having the same issue. It doesn't lose any fluid at all but somehow gets air in the system. Anyone have these symptoms before and fixed it? Thanks all help is nice

Re: Clutch constantly needs bled.
Thursday, December 06, 2012 2:48 PM
Clutch Master cylinder.






Re: Clutch constantly needs bled.
Thursday, December 06, 2012 6:21 PM
That's on the firewall correct? If so then that has been replaced.
Re: Clutch constantly needs bled.
Friday, December 07, 2012 10:58 AM
It takes awhile to get it all bled out. How long has it been going on since the last time you refilled the system?


"In Oldskool we trust"
Re: Clutch constantly needs bled.
Friday, December 07, 2012 6:53 PM
Z24Sunfire wrote:

That's on the firewall correct? If so then that has been replaced.


Have you replaced the slave then? Or just the master? Tberes really only three places you can get air into the system. The master, the slave and the lines. If the slave and master are new then Id make sure youre lines are solid and tight.



Re: Clutch constantly needs bled.
Saturday, December 08, 2012 1:15 AM
As long as it's been going on it should have been bled out lol. Doesn't matter much right now cause the cavfire died tonight :/ deer ran out in front of me and when I hit the brakes it slid off the road right into a guardrail and not just slid down the side I mean passenger front tire hit dead even with the beginning of the guard rail. Hit hard enough to push the rim back against the door.
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search