LD9 Spec Flywheel Issue - Transmission Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
LD9 Spec Flywheel Issue
Friday, February 08, 2013 8:56 PM
When I put the motor in my car 2 weeks ago, I also installed a spec aluminum flywheel. Flywheel was used and has unknown mileage on it. The frisction plate was replaced with a brand new one and the flywheel balanced with the rest of the rotating assebly,

Havent had any issues with the car since the first start up. Starting the car from work yesterday there was a weird tinny type sound, I figured it was my crank pulley bolt as it seemed to back loose. It was brand new from the dealer, was installed when everything was balanced and installed again when the motor was in the car. Hopefully it was a fluke or Ill just buy another new one.

Went to start the car this morning and it sounded as the bendix didnt engage, just the starter motor spinning. Tried it a couple times, did the old school hit the starter with a hammer to see if it would engage. Nothing. The last time I tried it I heard the weird tinny sound again. Thought I would make sure everything was tight and the flywheel wasnt loose or something.

I reached under the car and stuck 2 fingers in the inspection hole and hit the starter gear, it at that point completely slipped off the flywheel.

I plan to pull it tomorrow to find out exactly what happened and to see if it is fixable without being sent back to spec for reconditioning.

Anyone ever have this issue before? I believe the gear is pressed on and uses a couple bolts to keep from slipping. Not sure how it could come loose like it did.

Ill be sure to snap some pictures when I get it out.





"Oil Leak ? What oil Leak ? Oh, Thats Just The Sweat From All The HorsePower!!"


Re: LD9 Spec Flywheel Issue
Saturday, February 09, 2013 8:20 AM
That's the one issue I haven't seen from a Spec flywheel yet....


SPD RCR Z - '02 Z24 420whp
SLO GOAT - '04 GTO 305whp
RACER X - '78 Opel Kadett W41 Swap

Re: LD9 Spec Flywheel Issue
Saturday, February 09, 2013 8:08 PM
Yeah it is very annoying. I got the flywheel from canadian scott, lol. It seemed to be in great condition. There was no movement in the gear prior to installation. I just cant remember if it uses bolts or rivets.


"Oil Leak ? What oil Leak ? Oh, Thats Just The Sweat From All The HorsePower!!"

Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search