4T40E Won't shift into 4th - Transmission Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
4T40E Won't shift into 4th
Thursday, August 28, 2014 3:49 AM
Hello everyone,

Background: I have a 95 Sunfire that originally had a 2.3L with an auto trans. I have recently dropped a built LD9 with supercharger in it, I rewired the car with a harness out of a 2000 Sunfire GT and bought a 4T40E off of ebay for it. The car is tuned using HPTuners and is running a 2001 Sunfire OS/Tune. I also have the B&M Shiftplus hooked up to it. In my ignorance of the 4T40E I ran it for a bit with a quart and a half of fluid to much in the trans, but now have the correct amount of fluid in it.

Problem: The trans won't shift from 3rd to 4th, it shifts through the rest of gears fine. The first time I took the car out for the first time after I got it together I could have swore the trans shifted into 4th but as more time goes on I doubt myself more and more. In third it does seem to shift into an overdrive gear (which while traveling at 55 mph drops the rpms from about 3200 to 3000). Has anybody ever heard of this happening? Would the combination of have too much trans fluid and the B&M Shiftplus create too much pressure and cause this? Or did I just get a bad trans?

Thank you,


Bob

Re: 4T40E Won't shift into 4th
Thursday, August 28, 2014 6:40 AM
My Responses are in Blue
Robert Nantau wrote:

Hello everyone,

Background: I have a 95 Sunfire that originally had a 2.3L with an auto trans. I have recently dropped a built LD9 with supercharger in it, I rewired the car with a harness out of a 2000 Sunfire GT and bought a 4T40E off of ebay for it. The car is tuned using HPTuners and is running a 2001 Sunfire OS/Tune.
Is there any way you could send me a copy of the tune? The actual HPTuner file.
I also have the B&M Shiftplus hooked up to it. In my ignorance of the 4T40E I ran it for a bit with a quart and a half of fluid to much in the trans, but now have the correct amount of fluid in it.
If the car is truly tuned with HPTuners there should be absolutely no need for the shiftplus. All the shift perimeters can be changed with HPTuners.

Problem: The trans won't shift from 3rd to 4th, it shifts through the rest of gears fine. The first time I took the car out for the first time after I got it together I could have swore the trans shifted into 4th but as more time goes on I doubt myself more and more. In third it does seem to shift into an overdrive gear (which while traveling at 55 mph drops the rpms from about 3200 to 3000). Has anybody ever heard of this happening? Would the combination of have too much trans fluid and the B&M Shiftplus create too much pressure and cause this? Or did I just get a bad trans? A few companies remove 4th gear for "built 4T40s and 4T45e." If this is a plain old 4T40E I think the tune may be keeping the car from shifting into fourth. If a setting is wrong the 4T40E will not even try to shift into fourth. Also, your shift solenoids should be fine, since you wouldn't get into reverse either if one of the two were damaged.

Thank you,

Bob


This is the solenoids used for 1st to 4th gear in almost every GM four speed.

1st gear - on - on
2nd gear - off - on
3rd gear - off - off
4th gear - on - off



Re: 4T40E Won't shift into 4th
Thursday, August 28, 2014 6:52 AM
I'll send you the file as soon as I can get a hold of it, I'm at work right now. I'm not to familiar with tuning the trans so I'm not sure how to make the shifts harder like the B&M does. The person I bought the trans off of claimed it has 50,000 miles on it and it was from a junkyard so it should be stock.

Thank you,


Bob
Re: 4T40E Won't shift into 4th
Thursday, August 28, 2014 6:58 AM
Just email it to my email address in my profile.

I can tell you the changes need to eliminate the B&M also. A few people are running trans tunes I helped them with.





Re: 4T40E Won't shift into 4th
Thursday, August 28, 2014 9:57 AM
There are a lot of little changes in everything. It is pretty much a stock GM Reflash file with little tweaks.

I'll compare more when I get time. Might have something to do with the RPM and MPH shift points.

I assume your running stock injectors?

Where did you get the Re-Flash from?





Re: 4T40E Won't shift into 4th
Thursday, August 28, 2014 10:26 AM
The Injectors are the stock 310cc for the supercharger and the tune is from the hp tuners repository.

I tried to play around with the RPM and MPH Shift points but I don't know enough about the trans tuning to figure it out.

Thank you,


Bob
Re: 4T40E Won't shift into 4th
Thursday, August 28, 2014 10:28 AM
Yeah, I'll look at it, and update later this evening when I get time.





Re: 4T40E Won't shift into 4th
Tuesday, September 09, 2014 9:48 AM
Hey just wondering if you ever had time to check that out. I'm still having the issue and I'm considering changing the transmission out, but I really don't want to do that if it is just the tune and I am gonna have the same issue.

Thank you,


Bob
Re: 4T40E Won't shift into 4th
Tuesday, September 09, 2014 10:36 AM
I would change the shift MPH down a few mphs and go from there. Honestly. I would flash a stock re-flash on the pcm and see if you still have the same issue.





Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search