VERY ODD Headlight Issue. Please read for details. - Newbies Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
VERY ODD Headlight Issue. Please read for details.
Thursday, September 15, 2011 5:07 PM
Ok so i dont even know if this is a good spot for this. Or even where im supposed to put this... Im new to J Body but not so new around a GM.. Lol.

Ok to start. I bought the car and the headlights were lets say, "Jimmy Rigged"... (AKA Hooked up to a toggle switch above the heater vent on the far drivers side.)
It worked but i had no high beams. Well trying to fix that kicked me directly in the @$$..
Back to square one: i had removed a front headlight wiring harness from another Z.
When i installed this new harness there was 2 "Relay like" boxes that were "cut off". I noticed in my harness that was installed on my car the 2 boxes were there. So; since my harness was mangled from the moron in the electrician/mechanical department who owned the car before me, i decided to cut these 'boxes' and replace them with 'Color Coordination' on to the new harness. Taped all the wires up wraped then in the plastic sleeves and installed the harness and all plugs in to correct place..

Now the tuff part. (well for me anyway)... Test Time

Results as Follows:

**With Key Off**
Park Lights - Both signals light up in bezel, no other lights
Lights On - headlights, both signals in bezel, no other lights.

**With Key On**
Switch off - no lights on
Park lights on - bezel shows both turn signals lit up, tail lights lit up. No other lights
Light switch on - headlights on. Both signals lit up on bezel.

Left turn signal - is slo - both bumper lights are flashing dimly. Rear tail flashes same as corner
Right turn signal is fast - corner light flashes, no bumper lights light is bright

Hazards - both corners flash bright, bumpe lights both flash (seeming dimmer) drivers dimmer than pass. 

Fog lights do not work AT ALL!


**With Car started**

Lights off- yellow headlight flashes in th dash, 

Parking lights- yellow headlight light still flashes, tails on no front lights both turn signals on in bezel pass side corner on, no bumpers. No drivers..

Lights on - Jus headlights. Both turn signals on in bezel
Left signal same as when car is not started. Normal speed. May seem faster
Right signal still blinks fast no bumper light

Thanks to ANYONE reading this as you may have atleast a bit of insight on how i can get some lights back in my car.
Hopefully i put it in the right location and hopefully ididnt miss anything.
I also teated another "Relay" in each one of the 4 slots in the harness but no changes during each test cycle...

I'm Stumped...

Re: VERY ODD Headlight Issue. Please read for details.
Thursday, September 15, 2011 8:18 PM
i read all the way until "taped up" do your self a favor and find what ever model cav you have at the junk yard and pull the full headlight harness from unplugging it from under the batter tray. this way you avoid all that splicing mess.



Re: VERY ODD Headlight Issue. Please read for details.
Friday, September 16, 2011 4:27 AM
Ok... Its raining in my Province today so hopefully tomorrow morning ill head to the U-Pick n haul off the bottom of the air box and the windshield resivior to get the new harness. (fun stuff)
Ide say i have to go there anyway but i dont :p

Either way i will test this tomorrow again and post results. I dont see how the "taped up" wires coud effect it but its worth a try; and well it is the ONLY bit of advice that was givin so far. Thx fer tha reply Azncav. ive seen alot of ur posts around jus searching and reading the forums.

Quick question however. Will ANY 96 - 99 Z'd Cavy have the same harness. Because i know from my last visit there was a Black 98 Z there...

Any additional info would be great.
Re: VERY ODD Headlight Issue. Please read for details.
Friday, September 16, 2011 3:50 PM
i dont see why not. i swapped both my 96 cav and my 99 cav to 2000-2002 headlight using the harness method and both times it was a plug n play for me.



Re: VERY ODD Headlight Issue. Please read for details.
Friday, September 16, 2011 4:17 PM
Two things. Check that there isn't a bad ground somewhere. Grab a test light and check wires going to the switch if there is no power coming out of the switch, there's your problem. If not keep checking down the line til it becomes dead.
Re: VERY ODD Headlight Issue. Please read for details.
Friday, September 23, 2011 1:14 PM
Bad ground it was. good call. I missed the second thing i believe tho. Maybe u just didnt say it. either way. Thanks. Wire was a little ripped and shredded. Still low beams will not work, but will still b replacing harness either way. Hopefully all works out.
Re: VERY ODD Headlight Issue. Please read for details.
Monday, September 26, 2011 3:25 AM
99 headlight harness is different than 96-98s.





Re: VERY ODD Headlight Issue. Please read for details.
Monday, September 26, 2011 7:06 PM
how so? mine looked exactly like the one in my 96



Re: VERY ODD Headlight Issue. Please read for details.
Tuesday, September 27, 2011 3:09 AM
I know they are grounded different. I'm not sure if they are plug-n-play. I was having a ground issue on the drivers side low beam, and had to find a GM wiring diagram. My Haynes said they were the same 96-99, but both my 99s headlight harness are different than my Haynes manual. I could probably get a picture last this week of my "bad" harness.







Re: VERY ODD Headlight Issue. Please read for details.
Friday, October 14, 2011 5:12 PM
lo beam issue sounds like the classic burnt out headlight switch
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search