strange throttle delay on 05 cobalt - Racing Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
strange throttle delay on 05 cobalt
Sunday, May 12, 2013 4:57 PM
My dad races an 05 cobalt on a 1/4 mile asphalt oval. Itís a base model, manual, with a stock 2.2 ecotec. Idk if itís a problem with traction control or what, weíve looked at multiple wiring diagrams and we noticed it does have 2 different speed sensors. When you try and step on the throttle coming out of the corner the car wonít accelerate until he gets onto the straightaway. The weird part is we changed from all-season tires to a Hoosier h6 (racing slicks) and the problem went away. Idk if the problem was fixed because he wasnít spinning the tire coming off the corner or if he was just keeping the RPMS a little higher. We did add about 1 Ĺ to 2 inches of stager when we switched tires as well. So idk there are three different things we changed to make the problem go away. The worst part is the fact that the race club decided to outlaw the tires, so were back to all-season tires. Does anyone know why the car acts like it did, or how to eliminate the problem? I know hpt could possibly fix the issue but, I donít feel like spending 600$ on something were only going to use once, and thereís no guarantee that it will fix the problem. I would be very grateful for any help you could give me.

Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search