HID help!:( - Exterior Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
HID help!:(
Saturday, August 04, 2012 4:47 PM
hey fella's, just bought a 02 cavi, has HID high beams, and they dont work, everything else works, including low beams, but on high beam the headlights dont ignite. i have NO clue what im doing when it comes to HID's... just wondering if anybody might know whats up, or where to start looking for issues.. and if someone can break down to me how they work..

Re: HID help!:(
Saturday, August 04, 2012 5:07 PM
I know someone more experienced than me will chime in, but I had to repin the blue 9007 connector on the HID harness side to get any high beams. I had to switch the blue and white cables in the plug.
Re: HID help!:(
Saturday, August 04, 2012 6:31 PM
i bought the car with them in it and he said theuly did work but stopped one day.. so u repinned them wires goin to the light itself, just switched them around,correct?
Re: HID help!:(
Saturday, August 04, 2012 7:26 PM
If its a 9007 bulb a high beam will not ignite. You need to look at the actual bulb and see if it has a magnetic base that allows the bulb to move to a high beam position. If it does more than likely the control box is not working as it should. The best way to check is wait til night time and try the high beam. You should be able to see it goto high beam. Honestly you need to check to see how the setup is. There should be the 2 ballasts along with a control box for the high beams.
Re: HID help!:(
Sunday, August 05, 2012 5:50 AM
i am unsure of what bulb it has. i can see it as 2 bulbs in the headlight, a large one and a smaller one with a white base. there is a aluminum control box, and an black plastic igniter box for each side. how can i tell what bulb it has? would it help if i took a picture and posted one?
Re: HID help!:(
Sunday, August 05, 2012 7:59 AM
Get some pics and return. Pull the headlight housing out and take both bulbs out too and take pics and seriously wear gloves and set the hid bulb on something soft that doesn't have a lot of lint. The oils from your skin will ruin a hid bulb.
Re: HID help!:(
Sunday, August 05, 2012 11:42 AM
heres a few pics... gonna rain so i didnt get to far into it.... i have noooo idea whats goin on here, nor any idea how they work... haha. anyway, heres a few pics, plus a side one of my tractor hah

Re: HID help!:(
Sunday, August 05, 2012 11:43 AM

Re: HID help!:(
Monday, August 06, 2012 10:20 AM
I see nothing but red x's. you can try to pm the pics or email them to me so I can see what kind of setup you are working with.
Re: HID help!:(
Wednesday, August 08, 2012 6:33 AM
j.s. ive never needed high beams with my h.i.d's



Re: HID help!:(
Wednesday, August 08, 2012 6:54 AM
DJ Beefy wrote:

j.s. ive never needed high beams with my h.i.d's


this



JBO Stickers! Get yours today!

Re: HID help!:(
Thursday, August 09, 2012 12:00 PM
the way mine is set up is my low beam is a regular headlight, and my high beam is the HID.....thats why my lows work
Re: HID help!:(
Friday, October 05, 2012 5:56 PM
i have the same trouble with mine.. no high beams. but when I turn my lights on the bright light thing comes on the dash.. the lights are really bright on low.. just bugs me that the bright light thing is on.. mine came with the car too.. have the relays and the two ballast things. but there is no names on my to know what kind they are. the ballast are black with all clip-in plugs. thats all i know on mine..
Re: HID help!:(
Wednesday, December 19, 2012 4:26 PM
^^^same problem with mine bought a set with hid lows and a 35watt halogen and didnt like it so got the ones with the magnetic base but it always says the brights are on
Re: HID help!:(
Wednesday, December 19, 2012 5:29 PM
Take the bulb out and see if its burnt? Usually when a h.i.d bulb goes there is alot of white residue on the inside of the bulb.
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search