led issue - Exterior Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
led issue
Monday, April 22, 2019 10:00 PM
So i just bought some jdmastar reverse lights and im having issues with them. I first tried one and it worked. Put the other one in and it popped the fuse. Didnt have a 10amp so i used a 20. Turned them on and they started to smoke, didnt even turn on. Any suggestions? I made sure the wires on the connections on the bulb were in the right position on the holder.


ReD RaiN

Re: led issue
Tuesday, April 23, 2019 7:07 AM
Hold on, is this legit or a troll? "I didn't have the correct fuse so I just slammed one in that's double size the wiring is rated for and now I can't understand why it smoked the wires!?" Damn man, a real mystery there..

I'll even help you identify the problem:

T!M8!T wrote:

jdmastar reverse lights




"In Oldskool we trust"
Re: led issue
Tuesday, April 23, 2019 10:17 AM
T!M8!T wrote:

it popped the fuse. Didnt have a 10amp so i used a 20. Turned them on and they started to smoke, didnt even turn on


Wait what?

Sounds like there was a short inside the second one, and the higher amperage fuse allowed the circuit to smoke...

Harness is probably foobarred now.


Edited 1 time(s). Last edited Tuesday, April 23, 2019 10:20 AM


Re: led issue
Tuesday, April 23, 2019 12:28 PM
Red 3 standing by.



RIP silver car. You will be missed.
Re: led issue
Tuesday, April 23, 2019 3:43 PM
Red October standing by.......




Re: led issue
Tuesday, April 23, 2019 7:25 PM
Red fox standing by


R.I.P darknstrangecavie
Re: led issue
Tuesday, April 23, 2019 9:28 PM
Yea yea joke if u must. I realise the 20 amp was too much. I wasnt home at the time so figured id just try that one since i didnt have no others with me. I thought maybe it was too much draw for the 10amp since it blew it. I also read somewhere sometime that someone had to us a 15 amp in theirs. Anyways i just replaced my old bulbs and everything is fine, its not like i let it sit there and fry to pieces. I contacted jdmastar and they told me there may of been an issue with the bulbs so theyre gonna send new ones. The leds are only 3w per bulb and run 12-24v operation so i dont understand what the issue was. So back to the original question, why would of it popped the fuse in the first place? I guess uzing the 20amp is prob why they smoked but why would one work then add the other and popped it? I also take it jdmastar is not good? The reviews seemed fine.. Btw it was only the one that smoked. The other just stopped workin. Possible i need resistors? It didn't flash when it did work. Maybe a bad fuse? Other opinions?


ReD RaiN
Re: led issue
Monday, April 29, 2019 5:47 PM
I know that LEDs are also one way. As in a one way electricity check valve. Might sound stupid but try turning them 180 degrees. I had some cheap ones and would only work one way. Key word had.... LED bulbs kinda suck. If you really want LED bulbs go with some sort of aftermarket housing but be aware if one LED burns out you need a whole assembly. I say just stay stock, that's what your system is set up to handle.
Re: led issue
Tuesday, April 30, 2019 9:40 PM
Thanks for the info. Didnt kno if one led went all wouldnt work but Yea, i heard flipping them can resolve the issue. I was hesitant to try that cuz id have to bend and move the prongs over on the led for alignment with the socket and didnt wanna break them. The thing that gets me tho is leds require less power, shouldnt the stock holder/wires be sufficient? Just waitin for the replacements and ill try again, with the correct fuse.. Ill update with results. I wanted to upgrade the old ugly lighting and trying to reverse at night out of town u cant see nothin, also have tinted windows. Ive upgraded some of my other lights as well. So far no other issues


ReD RaiN
Re: led issue
Wednesday, May 01, 2019 6:28 PM
you know a test light connected to ground will tell you what side the power is on. Takes the guess work out of it.
Re: led issue
Thursday, May 02, 2019 8:47 PM
You need 3156CK bulbs for LED reverse lights. The power and ground is wired differently then normal bulbs. If you order regular ones that will happen.




On the inside my car looks like a fighter jet.

Re: led issue
Thursday, May 02, 2019 9:26 PM
Rob Dotterer wrote:

You need 3156CK bulbs for LED reverse lights. The power and ground is wired differently then normal bulbs. If you order regular ones that will happen.

Ck bulbs are for the tails i believe. Ill have to check with a test light when i get my replacements. Hoping it was just a defective bulb since it did work at first


ReD RaiN
Re: led issue
Wednesday, May 08, 2019 9:24 PM
Just a lil update, received my replacements, got them installed with the proper fuse and everythings good to go. Must of just been that bad bulb.


ReD RaiN
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search