03 Z24.. Multiple Questions.. - General Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
03 Z24.. Multiple Questions..
Saturday, February 18, 2012 1:17 AM
First of all I would like to say... It feels good to be driving a J-body Cavalier.. I have always wanted a Z24 but always ended up with other cars (Lumina LTZ with 3.1, Beretta GTZ with Quad4, Cobalt SS with Supercharger) so now I have finally purchased a 2003 Cavalier Z24 today with the 2.2 Ecotec engine (as if you didn't know that lol)... Anyhow the main purpose of this car is to save me some money in fuel cost, I also have a 2005 Silverado 5.3 running 35's and it's costing me lots of money in fuel each month.. So I have been searching for a car in the past months (anything from Mazda3s, Cavalier/Sunfires and Honda Civics mainly) and I finally ended that search yesterday FINALLY !!!! (too many cars have had accident claims or too high KM).. Anyhow on with the reason I am posting...

So a little about the car.. So I got a wicked deal on this car compared to what others are selling in my area.. It's got 121,000km/75,000miles which is low. The car is in mint shape both running and body.. Oil sprayed and everything.. Came with 2 sets of rims/tires (winters and summers)... Clean both inside and out... Mint underbody.. Automatic and shifts perfect (I drive a 18 speed all day so as much as I would love a 5speed I just appreciate the automatic after driving a truck all day not to mention auto is better for my commute in traffic)... The car is in all around good shape.. There are some minor things I want to clear up here.. Not big issues for the most part and the only issue that is a little bigger I am already aware of prior to my purchase....

So here are my questions... 2003 Cavalier Z24

#1 - I noticed that the gear selections do not light up.. I have looked online and I don't really see any real answers.. I don't even know if they are suppose to light up or not.. I know there is a orange dot that shows the gear selection.. But are the gear selections (R, P, D, 3, 2, 1) suppose to light up or not?? If they are suppose to light up how do you go about getting to the connections??? If they don't light up then that solves my problem ...

#2 - The odd time when the car is turned on it makes a funny noise (and this doesn't happen all the time)... The noise to me sounds similar to the notice a intake would sound like when you hammer on the pedal.. Like I said this is intermittent and doesn't effect how the car runs... The car runs very smooth and sounds great.. This only happens when key is turned and the car is started.. It's just a split second thing.. I just wondering if anyone has a similar issue.. I remember the seller telling me something about it but I forgot what she has told me it was.. She has taken car to mechanic and they told her what it was and that is wasn't a huge deal.. If she emails me back I will update my post about this, unless someone knows what I am talking about.. I can also try to get a recording tomorrow and upload it

#3 - The drivers side window when going down slows down when it gets to a certain point, but the glass doesn't shutter nor does it stop or slow down to a crawl.. It just isn't as smooth flowing as the passenger side.. This is only when window goes down and not up.. Now my friend that owns a Sunfire (1997) says this is a common thing with these and that it's not a problem... I did notice it happen to a 2004 Cavalier I looked at awhile back so it seems like it could just be one of the quirks that happen that isn't a issue... Anyone else have a opinion on this??

#4 - The car only came with 1 key and 1 key fob.. No big deal I can get a key cut tomorrow for less ten $2... Now the key fob I can get 2 of them from ebay for $40 (same GM number and FCC number on the back of the current one I have)... My question is.. Is it possible to program this myself or do I have to have the dealer do it.. I haven't called them to see what they would charge me but I am willing to bed it's some stupid amount ... I am just wondering if I can do it myself.. I don't really need to get a spare one but for $40 for 2 new ones (the buttons are worn on the one I got which is normal), I'll just get them ... Depending on how much it cost to have them programmed of course...

#5 - This I think for now is my last question.... Now prior to purchase of the car, the seller told me that the "floater" on the fuel tank was broken (this is was a mechanic told her).. Now I don't know if they were trying to make money from her or not.... She just told me she resets the trip meter when she fuels, and when she gets to about 450-500km (279-310miles) she just fuels back up... Now I can do this as well but eventually for me personally this would get annoying.. I just like to have things working... So anyhow when I took the car for a test drive I noticed the fuel gauge go from 1/2 then to 1/4 and then to empty in a matter of minutes... So this to me indicates that the float is working, cause if it wasn't shouldn't the fuel gauge always be at empty ??? So I noticed that the fuel light and temp light were both on (temp gauge at 90)... Well the car isn't over heating and the car has gas... So my question do you smart j-body owners is.... Do you think that the possibility is more towards the cluster not working correctly and needing to be replaced or do you think that the floater is actually broken.. Like I said I figure if floater is messed then fuel gauge should always be on empty.. Like I said I was aware of the issue so even if it is the "floater" which I know requires changing the fuel pump (stupid that you can't just do floater) that is fine.. I can drop the tank and do this myself to save me money.. I also can get the parts as discount... But if I don't have to do all that work and it's more likely the cluster well then this is not only the cheaper way it's also the easier way... If it in-fact the "floater" then I won't bother doing and I'll probably just do the trip reset when i fuel up.. Cause annoying as that may be I don't think it's worth a $300 fuel pump replacement .. I wish you didn't have to drop the tank it would make life that much easier as well... From what I read online it seems like these cars have issues with the fuel pumps going out on them, not the floater.. Well this car has no issues delivering fuel (knock on wood)..

Like I said these issues aren't huge problems... The main thing is that this car is in mint shape, runs perfect, low km, saves me fuel, great purchase price.. The issues I have listed are more of picky issues then things that need an sort of immediate attention... I can drive the car as is and not worry about anything.. It's just I like things to be working like that should and I hate dash lights on that shouldn't be on lol..

Thank you all for any help you can provide me.... Sorry if i poste din wrong spot but I figured I have a bunch of different questions that would belong in several different forum areas... So this is much easier...

Re: 03 Z24.. Multiple Questions..
Saturday, February 18, 2012 1:49 AM
Also.... If I can say get my hands on a cluster to try it out to see if that is the problem... Will it work if I just plug it in and show the correct mileage or will it need to be programmed for my car??
Re: 03 Z24.. Multiple Questions..
Saturday, February 18, 2012 5:20 AM
1# not sure, never actually driven an auto j

#2, do you mean like a sort of induction roar sound? or some kind of rattle?

#3, pull the interior door panel off and have a look, mine had the rubber come out the the tracks a few times, may be the problem, maybe not

#4, I think on 00+ cars the fob has to be programmed via a tech@ but i've also heard otherwiseso google it and try i guess.

#5, the shop wouldn't have know if it was the float that was broken unless they dropped the tank. it's probably the sender itself. the sender unit and pump assembly is one piece (although you can remove hte pump from it) you can pull this out and repalce the sender (with the float), last i saw they were $20 -$30 USD. but you do have to drop the tank to get at it and replace the seal when you do it it's only a couple extra dollars.

if the cluster is the problem, switching it out wont affect the odometer, that info is stored in the BCM.

What colour is the car and is it stock?

I am in Whitby also.

Also calling that someone will post or go to post "there's no such thing as an 03 Z24"

Re: 03 Z24.. Multiple Questions..
Saturday, February 18, 2012 9:55 AM
#2 Question.. She says that the mechanic told her it's moisture in either the starter or the fly wheel.. Only when it's cold it does it and not all the time... She hadn't has a problem with it since she owned the car and it was like that when she purchased it... So I guess I will keep it like that until sometime like the starter goes... As for the flywheel I dunno lol
Re: 03 Z24.. Multiple Questions..
Saturday, February 18, 2012 8:53 PM
Dave - Well as for the problem with the "induction sound" I posted I guess at the same time you posted.. So it is below your post.. The starter or fly wheel has moisture or something in it that is causing this.. It doesn't affect the car and has been like this for a while I was told by the last.. It's not a problem and only happens the odd time..So I guess unless something goes its not a huge deal... If it is the starter doing that then if the starter fails then I will just replace it.. But if it is the fly wheel then I dunno what to do....

The car is the same as yours.. It's silver in colour and it's completely 100% stock... Minus some tinted windows.... It will pretty much just be staying stock.. Like I said it's just a 2nd car for me to save me gas from driving my truck to work.. I guess really this car will not become my primary driver and my truck is there for when I need it to tow my ATV and trailers..... The only things I MIGHT do is order some lowering springs in April for it (Canuck Motorsports probably) and that pretty much well sums up what I am gonna do to it.. No exhaust (my truck is loud enough and it's just nice to have a quiet car for my commute).. No rims just gonna roll on the stock Z24 rims.. Unless a good deal comes up on a set...

I am not sure what you mean by "Also calling that someone will post or go to post "there's no such thing as an 03 Z24" ---- I assume your talking about our southern neighbours that don't realize that we have the Z24 package still in Canada on these new models.... As the Z24 models come loaded with power, sunroof, skirt skit, chrome rims, muffler "tip" and I think that's it.... Or post is a little confusing as I am not sure what your trying to say lol.. Are you trying to say "you call on anyone on the board to try to say we don't have a Z24 production in 03???

Any other help from anyone would be appreciated..

Also if it is any help.. Today when I was fuelling I couldn't put the nozzle in all the way otherwise it would automatically shut off.. Is this a problem for these cars or would this be a relation to my fuel light issues.. Or is it just how the piping is bent.. Maybe next fill up it will not do this, this is my first fuel up.. Also what is the average KM per tank and how big is the tank??
Re: 03 Z24.. Multiple Questions..
Monday, February 20, 2012 8:11 PM
The bulb is burned out in the center console. 194 I believe.

Forum Post / Reply
You must log in before you can post or reply to messages.


Start New Topic Advanced Search