BM Shiftplus Install With Pictures #70380 - Page 12 - Transmission Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Re: BM Shiftplus Install With Pictures #70380
Friday, July 10, 2009 7:09 PM
ok so i def like this product....it works but not in the caliber that others say it will.....shifting is actually felt instead of heard for once which is nice....i'd say overall for a 40 dollar mod it's money well spent.....way to go b+m!!!!!!!!!!!!!!!



Re: BM Shiftplus Install With Pictures #70380
Thursday, July 16, 2009 9:51 AM
Thanks for the review!

If any one needs one we have them in stock, for a quick ship, at www.TurboTechRacing.com



-Aaron
www.TurboTechRacing.com

Performance Parts For Cavalier, Sunfire, Cobalts and More!!!
Re: BM Shiftplus Install With Pictures #70380
Saturday, July 25, 2009 11:25 AM
Kind of a unique situation here. I had my tranny connector replaced, so the shop replaced it with one that has all white wires. So is it just the top 2 wires on the connector I should tap?



Re: BM Shiftplus Install With Pictures #70380
Tuesday, July 28, 2009 7:59 AM
is it the same plug on a 98 sunfire gt
Re: BM Shiftplus Install With Pictures #70380
Saturday, August 01, 2009 8:37 PM
anyone know if i might beable to use this on my 91 Regal ?


ShowOff Customz
03 Cavalier
73 Beetle
68 Fairlane 500


Re: BM Shiftplus Install With Pictures #70380
Thursday, August 06, 2009 1:55 AM
I own a 2003 Pontiac Sunfire with 2.2 ecotech and Automatic tranny. I need to replace the connector that the two wires go to. Does anyone know the part # or where I can get one at? With my luck i'm sure i'll have to buy the whole damn harness
Re: BM Shiftplus Install With Pictures #70380
Monday, August 10, 2009 9:49 PM
So I have the 3t40 trans (the 3 speed) I know the b&m shift plus wont work for mine but
my trans is vac controlled un like the 4 speed elec .
Will the part number BMM-70383 which is supposed to be for the vac controlled. will it work
might help for us people with the 3 speed if some one can help thanks in advance

get rich or go for broke
Re: BM Shiftplus Install With Pictures #70380
Sunday, August 30, 2009 11:53 PM
Just installed my shiftplus this weedend and damn i love it I ordered it from turbotech(thx a lot). my package was in his box since 3 months due to the wrong photo posted on page 9, just wanna say thanks so fuc***g much to the guy who redone the explanation, really appreciated!



Re: BM Shiftplus Install With Pictures #70380
Tuesday, September 08, 2009 10:28 AM
Hi guys, I'm new to the forum and I got to know the BM Shiftplus kit thru this thread so I got very excited about the idea of getting it for my 99 2.4 Sunfire and I ordered one from Summit Racing in Ebay and after ordering, I asked them (Yes I was an idiot =)) if it was going to fit my Sunfire and they said no.. So I don't know now if I ordered the right one or if they're just checking in a catalog that doesn't have my car listed or what? Can somebody help on this?

This is the item I purchased:

http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&item=390090781681&viewitem=&_trkparms=algo%3DLVI%26its%3DI%26otn%3D2&category=33727

And this is what I was told:

Subject
B&M Shiftplus 70380

Discussion Thread
Response (Jason)09/08/2009 11:18 AM
Hello,

Sorry, this will not fit your Sunfire. We don't carry a shift kit for your application.

Thanks,

Summit Racing Sales
Customer 09/06/2009 12:26 AM
Hi I'd like to know if this kit B&M Shiftplus 70380 automatic transmission
improving kit fits a 1999 Pontiac Sunfire 2.4L? and if the kit comes with an
install guide?

Thanks,

Rodolfo
Re: BM Shiftplus Install With Pictures #70380
Tuesday, September 08, 2009 12:09 PM
Ok I just went thru the whole thread and it looks like you guys are using the same kit I purchased which is for 4L60E and 4L80E transmissions and having in mind that the Sunfire 2.4 has 4T40E transmission I think that would probably answer my question but... Is it right to use this kit if it's for other transmissions? I'm wondering if I will have any bad effects on my transmission after a while...
Re: BM Shiftplus Install With Pictures #70380
Tuesday, September 08, 2009 12:52 PM
yes its the right one, follow the directions, it will work with the 4T40E in any car. be careful with your wiring.








Re: BM Shiftplus Install With Pictures #70380
Tuesday, September 08, 2009 12:56 PM
Cinny wrote:

yes its the right one, follow the directions, it will work with the 4T40E in any car. be careful with your wiring.


Thanks for your quick reply! by the way.. how long have you had this mod by now? any problems with the trans?
Re: BM Shiftplus Install With Pictures #70380
Tuesday, September 08, 2009 1:44 PM
no problems, i had it on for about 3yrs, just didn't put it back when I did an engine swap because i now have HPTuners and can do the same thing in there.






Re: BM Shiftplus Install With Pictures #70380
Tuesday, September 08, 2009 2:09 PM
Cinny wrote:

no problems, i had it on for about 3yrs, just didn't put it back when I did an engine swap because i now have HPTuners and can do the same thing in there.


Awesome! Thanks a lot man
Re: BM Shiftplus Install With Pictures #70380
Friday, September 18, 2009 1:59 PM
Well I installed the Shiftplus and everything seemed to be ok so I took the car for a short ride and I got the Check Engine and ETS OFF lights on like some other folks in this thread... The kit seemed to be doing its job ok since I could notice that it was shifting with no delays and there was like a little push each time I shiftted but I didnīt like the fact of getting the Check Engine light on so I decided to get rid of the kit and put everything back on its place.. Did any of you guys found the reason why the lights came on?
Re: BM Shiftplus Install With Pictures #70380
Friday, September 18, 2009 2:23 PM
It may have been installed incorrectly. Your best bet would be to get the cel codes checked.





* * BIG FOR SALE POST * *
Re: BM Shiftplus Install With Pictures #70380
Friday, September 18, 2009 2:32 PM
tha_prowler wrote:

It may have been installed incorrectly. Your best bet would be to get the cel codes checked.


Yeah I should get the codes... But Iīm pretty sure I used the right wires since I checked like a million times this thread and the kitīs install guide.. Just as an FYI my car is 99 Sunfire 2.4.. Maybe the kit behaves differently depending on the year...
Re: BM Shiftplus Install With Pictures #70380
Friday, September 18, 2009 4:23 PM
So just curious, does anyone know how this works, ex. different resistance values for different stages, or is there some all out board in these?


Hellraiser and Lil Lightning
Re: BM Shiftplus Install With Pictures #70380
Friday, September 18, 2009 8:36 PM
I get the feeling it's just one resistor/diode/capacitor/element for each setting.



Re: BM Shiftplus Install With Pictures #70380
Tuesday, November 10, 2009 8:12 AM
Im not sure if its just @!#$ up bad timing but 4 days after i put mine in 2 shift solinoids and torque converter went bad=\


http://www.cardomain.com/ride/3364129
Re: BM Shiftplus Install With Pictures #70380
Monday, November 16, 2009 11:32 AM
fexican wrote:

Im not sure if its just @!#$ up bad timing but 4 days after i put mine in 2 shift solinoids and torque converter went bad=\

ignore that >.> moisture in the hook up gave false codes


http://www.cardomain.com/ride/3364129

Re: BM Shiftplus Install With Pictures #70380
Thursday, April 01, 2010 10:03 PM
This will work for 4t40e tranny in an 03 cavalier, correct? I was told it wouldn't work.
Re: BM Shiftplus Install With Pictures #70380
Friday, April 09, 2010 4:55 PM
so anyone that has installed the B&M shiftplus shift kit did you get a noticable difference???? cause im not and i know i hooked it up right im thinking it might be the cheap wire connectors that come with the kit.
Re: BM Shiftplus Install With Pictures #70380
Friday, April 09, 2010 5:11 PM
It's very noticeable for me. Rather than the car "sucking back" between shifts it jerks forward.



Re: BM Shiftplus Install With Pictures #70380
Thursday, April 22, 2010 9:32 PM
i have a 2005 cavalier and i heard the wireing was diff and wondering if anyone knew how to instal it
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search