Loss of radio channels - Maintenance and Repair Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Loss of radio channels
Wednesday, August 11, 2021 11:30 AM
Hi Al. Hope everyone is doing well! A little while ago I noticed some my radio channels are not coming in a strong and Iím not quite sure where I have to start looking but it almost seems like something may have shorted out or a bad ground or something. I am driving my trusty 1989 Pontiac Sunbird LE2 door. Just got a new clutch in a little while ago and I am totally enjoying driving the car!

Re: Loss of radio channels
Tuesday, August 17, 2021 12:49 PM
Sounds like a antenna problem, might be rusted at the antenna or the cable end to the radio, or the cable itself.

Mine is in a rusty enviroment but works fine, but listen to the motor because its music to my ears...lol ( never a big radio fan)

Doug in P.R.


92 Pontiac Sunbird LE, 2.0, AT, Red / Black with Grey 154K miles. Hurricane Maria Survivor ! ( It takes a licking and keeps on ticking ! ).....in Salinas, Puerto Rico!




Re: Loss of radio channels
Thursday, August 19, 2021 6:15 PM
I'd see if the connector at the antenna is firmly attached (without corrosion) and if the nearby cable is damaged.

Otherwise you could pull the radio and see if the coaxial antenna plug is tightly connected (without corrosion).

If the connectors at either end get, corroded, reception will weaken (not die) as it get more and more corroded. (Same thing can happen at your house with old exterior coaxial antenna or cable connections.)
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search