2.2 dudget boost project issue - Performance Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
2.2 dudget boost project issue
Sunday, January 24, 2016 3:25 PM
I'm doing my first turbo setup on my 99 s10 2.2. This is a low dollar project ...ebay,amazon, and junkyard parts. The turbo is a. Volvo td04hl-16t that I'd like to run 6psi with. I took her for a ride today but it's only building 3psi boost. Comprossor bypass is working and when I manually rev the motor from under the hood the wastegate actuator is moving. I do have n exhaust leak well after the down pipe under the truck but I didn't think that would be my issue. Could anyone offer any help or knowledge on this? I'd really appreciate it. Thanks
Milo

Re: 2.2 dudget boost project issue
Sunday, January 24, 2016 7:38 PM
If your Volvo turbo is like mine it has the oddly shapped flange. You have to run a adapter plate between the turbo and manifold so you don't have an exhaust leak there. Other than that it sound like a boost leak maybe? Do you have a manual boost controller, are you intercooled, do you know what the wastegate is set to?
Re: 2.2 dudget boost project issue
Monday, January 25, 2016 4:05 AM
I do have the adapter plate. I'm using the Audi side mount intercooler and the wastegate is the factory actuator and gate. I pretty sure it's an 8lb acuator. When I rev the engine in nutral the actuator moves but I was under the impression that it will not build boost unless under a load so I was thinking the acuator could be my issue. Should I try to adjust the rod shorter?
Re: 2.2 dudget boost project issue
Monday, January 25, 2016 4:43 AM
No boost controller by the way. This is low boost...5-8 psi. From what I understand that's about all the stock motor can handle
Re: 2.2 dudget boost project issue
Monday, January 25, 2016 6:14 AM
The actuator will start to open before you build boost. For example my bov opens at -10 HG vacuum. Just as long as there is positive pressure. Have you driven the truck? is it only building 3 psi at WOT? My suggestion was going to be to adjust the rod but I would check for boost leaks first.
Re: 2.2 dudget boost project issue
Monday, January 25, 2016 7:14 AM
Yes I have drivin at. 3 psi at wot is all I'm getting. This is a remote mount setup. I forgot to mention that. Today when I get home I'll check the connecting pipe from manifold to turbo and check for boost leaks if that is leak free. Thanks for the help. I'll let you know what I come up with
Re: 2.2 dudget boost project issue
Monday, January 25, 2016 2:38 PM
Sorry to be a pain in the ads but I really do appreciate the advice. I didn't get a chance to work on it today but I did make a boost leak tester. Hopefully before the weekend I can find time to use. I wanted to ask you about the breather hose off the valve cover. Does that hose need to be reinstalled pre turbo on the cold side?
Re: 2.2 dudget boost project issue
Monday, January 25, 2016 4:20 PM
It technically needs to see vacuum so it needs to be connected to the turbo intake. A lot of people just put a breather on it though. If your remote mounted then it could be the length of piping creating a drop in pressure. Similar to running a giant FMIC.
Re: 2.2 dudget boost project issue
Monday, January 25, 2016 4:30 PM
Also just an FYI I'm running 8psi on my car. Which puts my car at 220whp and 240tq. The boost pressure number is meaningless as far as a limit for a number. The bottom end can only hold around 275whp before you start sacrificing reliability. You can run 20psi all day as long as your not over that 275whp. Since your running remote mount I assume you decided to go without an intercooler. That's alright with low boost applications but, if you want to turn up the boost I highly recommend installing an intercooler. Just keep an eye on your IAT's as you turn up the boost without an intercooler.
Re: 2.2 dudget boost project issue
Monday, January 25, 2016 4:52 PM
I did fit a small side mount cooler under the hood. I'd send a pic but it's to large and will not upload. The cooler I am using is out of an Audi A4. Its 2.25 in and out. Pulled it out of the junkyard
Re: 2.2 dudget boost project issue
Monday, January 25, 2016 4:58 PM
Would you recommend just using a breather cap? Also...yes the turbo is remote mount but it's still under the hood on the manifold side so the pipe is only about 18in. Long. I used a manifold for a cavalier but the flange sits to close to the fire wall

Re: 2.2 dudget boost project issue
Monday, January 25, 2016 5:01 PM
This makes sense. I never thought of it like that. Thank you
Re: 2.2 dudget boost project issue
Monday, January 25, 2016 5:27 PM
If you don't plumb it into the turbo intake you need to use a breather cap. I run a catch can so that is inline between the valve cover and turbo intake.
Re: 2.2 dudget boost project issue
Monday, January 25, 2016 5:30 PM
I know my posts are all over the place here...sorry about that. I don't think I can just add to my last. I also wanted to mention that I clocked the turbine houing on this. It had a tiny nipple on each side that I removed to allow me to do this. I was a little worried about doing this at first but the more I thought about it I didn't see any reason not to. Everything sealed back up tight and with no rotation even if you tried to fire it to move plus it's now mounted on a bracket that will now allow it to move. Have you ever heard of anyone doing this? Sorry again for a million questions you have been very helpfull and I'm eager to learn. Thanks again
Re: 2.2 dudget boost project issue
Tuesday, January 26, 2016 12:28 PM
After doing some digging under the hood I found a leak at the flange with the volvo t3 adapter and also with the leak tester I made I found that the air temp Sen. On the intake tube was leaking. I added a second gasket to the flange and that solved that problem and I moved the sensor pre turbo just behind the air filter. Took her for a ride and now it's making 7psi @ Wot. Still need to do some adjustments and it has a good bit of lack ( don't know if I can do anything about this?) buts its working and running pretty good. Did not even trip a MIL light. Thanks again for all the help
Re: 2.2 dudget boost project issue
Tuesday, January 26, 2016 1:06 PM
So you moved the IAT sensor to before the turbo? If so bad move. It needs to be after the intercooler. GM has a screw in style IAT that was used on a few different cars that you can weld in on the piping to keep from leaking.



FU Tuning



Re: 2.2 dudget boost project issue
Tuesday, January 26, 2016 1:58 PM
Thanks for that info. Just so I know for my knowledge what is the harm in doing this? Also any thoughts on what model gm to get that part? I'll go junk yard hunting this weekend
Re: 2.2 dudget boost project issue
Tuesday, January 26, 2016 4:47 PM
milo guzman wrote:

Thanks for that info. Just so I know for my knowledge what is the harm in doing this? Also any thoughts on what model gm to get that part? I'll go junk yard hunting this weekend


incorrect reading for tuning. You want the IAT reading of the air going into the motor. When it first comes out of the turbo it is the hotest. After the intercooler it is cooler.

2.3's had a plastic version screw in, but I believe the 3 gen camaro's. It has been posted on here if you look around.



FU Tuning



Re: 2.2 dudget boost project issue
Tuesday, January 26, 2016 5:14 PM
That makes sense. Thanks for the info...it's much appreciated. Just to be clear though, in till i get to moving it in the next week or two it will not cause the engine any harm?
Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search