The Gravana Coilover Thread (Troubleshooting, etc) - Page 7 - Suspension and Brake Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Re: The Gravana Coilover Thread (Troubleshooting,
Thursday, May 04, 2006 2:03 PM
I figured it out finally....and then I couldn't get the top bolt on the drivers side to go down! It would just spin the shaft. I limped it to a nearby tire shop and they let me impact it on....now it's fine....I'm likeing it alot.


02 Subaru Impreza WRX Wagon


Re: The Gravana Coilover Thread (Troubleshooting,
Thursday, May 04, 2006 5:05 PM
am i the only one on 2k+ mounts???



Re: The Gravana Coilover Thread (Troubleshooting,
Thursday, May 04, 2006 5:09 PM
mandy (lambofgoddess) is on 2k+ mounts i believe. she and pj had everything figured out and it was riding fine. and then she had a little incident with the coilovers. you can read about that here . as soon as i saw what happened with hers, i went outside and double checked and made sure everything was tight on my setup





Re: The Gravana Coilover Thread (Troubleshooting,
Thursday, May 04, 2006 6:09 PM
wow that kinda sucked


kinda still looked like something was missing in her set up







Re: The Gravana Coilover Thread (Troubleshooting,
Wednesday, May 10, 2006 8:04 AM
Wow that does suck. Sorry to see. Now that I've put some miles on mine since I got my car back. I'm really starting to enjoy these a whole lot more.



Proud member of JBOK (J-bodies of Kentucky)



Re: The Gravana Coilover Thread (Troubleshooting,
Tuesday, May 23, 2006 7:23 AM
I'm having the most difficult time with these things. I think I got a lemon set.

Anyone else have a problem with the adjustment screws getting stuck? So far, 2 have done this to me. The first one was a front strut, I got it to move by grabbing a pair of rubber tipped pliers and forcing it to turn, it now moves like butter. Now the back one on the same side has done the same thing. And I'm stuck at a very soft setting in the rear (not fun at all). What is the problem? I've tried taking the preload off, tried putting more on, jacked it in the air, and this thing still will not budge.


02 Subaru Impreza WRX Wagon

Re: The Gravana Coilover Thread (Troubleshooting,
Tuesday, May 23, 2006 8:22 AM
havent had any issues with mine

and im close to 8,000 on mine







Re: The Gravana Coilover Thread (Troubleshooting,
Tuesday, May 23, 2006 9:00 AM
=c(


02 Subaru Impreza WRX Wagon

Re: The Gravana Coilover Thread (Troubleshooting,
Tuesday, May 23, 2006 1:13 PM
mine would only let me go to 7 on one of teh fronts.....just grip it with ur fingers and twist, it will go futher. it just wont feel liek it should. Jim said it was a common problem...............glad he made these so nice for us....ahem



Re: The Gravana Coilover Thread (Troubleshooting,
Tuesday, May 23, 2006 5:36 PM
Jim didn't make them... ahem, however he did HAVE them made for us. If you're experiencing any issues with them, Jim or any of the Gravana staff will be more than willing to help you out. This stuff happens when things first hit production, it's like buying the first year model of a car.... ish happens.



Re: The Gravana Coilover Thread (Troubleshooting,
Wednesday, May 24, 2006 6:12 AM
i agree, when things first hit production there are bumps, however i was the 3rd bath of these things. by then at least some of the bugs shoul dhave been worked out.




Re: The Gravana Coilover Thread (Troubleshooting,
Thursday, June 01, 2006 3:20 PM
I'm having issues with my strut mount, have been for a while. It is clunking. The mechanic must not have set it up correctly. I was wondering when these rumored pilow ball mounts for the gravana coilovers are supposed to come out, if someone knows how to fabricate a tein pillowball mount to these, or if I should go buy some KYB front upper strut mounts. The clunking is really getting to me... don't know what I should do.
Re: The Gravana Coilover Thread (Troubleshooting,
Thursday, June 01, 2006 5:36 PM
i havent talked to them about the mounts in a while

best i can tell you is to call them







Re: The Gravana Coilover Thread (Troubleshooting,
Friday, June 02, 2006 6:26 PM
i got my set about 3 months ago.... thinkin of selling them...anyone interested....lil to rough for me......thinking bout going airride




~ENJOY THE DRIFT~

Re: The Gravana Coilover Thread (Troubleshooting,
Sunday, June 04, 2006 10:17 AM
they are making some sort of replacement to fix any mount issues

chad told e-mailed me something about they are making camber plates that sit on the top of the mount or something and will eliminate any problems with the stock mounts, ill have to give him a call again and find out what exactly they are doing because i'm still at stock hight



Re: The Gravana Coilover Thread (Troubleshooting,
Sunday, June 04, 2006 7:08 PM
So they won't be making mounts? Just camber plates to fit over the OEM ones?



Proud member of JBOK (J-bodies of Kentucky)



Re: The Gravana Coilover Thread (Troubleshooting,
Monday, June 05, 2006 8:04 AM
Gravana/B&G are working on a full front strut mount replacement that will have camber adjustability.







Re: The Gravana Coilover Thread (Troubleshooting,
Monday, June 05, 2006 3:37 PM
^^exactly, i will call on wendsday if i get some time and find out how far they have got with them, ill let you guys know



Re: The Gravana Coilover Thread (Troubleshooting,
Saturday, June 10, 2006 1:35 PM
i'm a little late to post, but as for what happened to my coilovers that was partially user error, and after miles and enough launches at the track i think it just finally gave way.

as of a couple days ago, all the coilovers are on..and its riding beautifully. i have about a finger of wheel gap and yeah i love them. =]





Re: The Gravana Coilover Thread (Troubleshooting,
Saturday, June 10, 2006 7:53 PM
im happy to say that i have a new found respect for my gravanas... today i dialed down the pre load on my gravanas on the front and made a couple more adjustments all around, and about 70% precent of the harsh hitting and bounciness went away and the handleing dramatically improved... i think i hit the sweet spot on my gravanas....and i also drilled out the mount holes on the fronts where the camber bolt would go and readjusted my camber to remove the positive camber that i had...so happy i baught these things....




~ENJOY THE DRIFT~

Re: The Gravana Coilover Thread (Troubleshooting,
Saturday, June 10, 2006 11:46 PM
Lamb Of Goddess wrote:

i'm a little late to post, but as for what happened to my coilovers that was partially user error, and after miles and enough launches at the track i think it just finally gave way.

as of a couple days ago, all the coilovers are on..and its riding beautifully. i have about a finger of wheel gap and yeah i love them. =]

How much did one replacement strut cost?








Re: The Gravana Coilover Thread (Troubleshooting,
Saturday, June 24, 2006 4:37 PM
This is a question for those who have the gravana's dialed in for smooth driving (you know, not the bobble-head deal going down the road). I've played with mine quite a bit and can't seem to find a sweet spot. I know everything is personal preference, but what are you looking at for strut height and how much compression are you giving the springs? Measurements, etc, would help greatly. Where I have mine set, it seems to absorb bumps a bit rough as well as re-bounding too quickly. Note that I hardly have any compression being put on the springs and ride height is at about 2 fingers' width gap all around. Any help would be greatly appreciated.





Re: The Gravana Coilover Thread (Troubleshooting,
Thursday, September 07, 2006 3:57 PM
I love these coil overs. Well at first I id now I hate driving my car. Up until the day I got to cali with them they were perfect. No clunks no nothing. Now when I turn I get a rubber on metal creek when I turn and also I get a pop from sounds like the front passenger side. My mounts are the 00+ and the rubber on the top part is all squeased into the cnter hittign the actual strut part that is sticking out. Now my shop that installed them said he modified the 00+ per gravanas instructions over the phone. I had told him he would need to do 95-99 but gravana told him thye would be fine or so he tolds me.

Who is running camber plates with these and which ones. Also do they make a solid rear mount to match the solid front with camber.


Disclaimer: Dey see me Trollin' Dey hatin' for trollin dey trying to catch me ridin dirty.

Re: The Gravana Coilover Thread (Troubleshooting,
Wednesday, September 13, 2006 8:03 PM
Ok so I have a problem they kinda clunk when I hit harsh bumps even at low speeds. I dunno if it the struts or something else. Its not really loud but annoying. I know there not supposed to be totally quiet. Oh yeah I am running camber plates on the front and prob blown 00+ stock rears.


Disclaimer: Dey see me Trollin' Dey hatin' for trollin dey trying to catch me ridin dirty.

Re: The Gravana Coilover Thread (Troubleshooting,
Thursday, September 14, 2006 12:21 AM
mounts are prob gone, i replaced mine and all those problems went away




Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search