The History of the EvoFire - Page 6 - Photos & Media Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Re: The History of the EvoFire
Saturday, July 14, 2012 10:09 PM
Looks great and that's one hell of a tight fit...





Re: The History of the EvoFire
Saturday, July 14, 2012 10:49 PM
Tinkles(KGM) wrote:

Holy @!#$ is that snug in there.


yup bit it fits and fits good! putting 90s on the top two bungs and i will look a lot better.




Re: The History of the EvoFire
Wednesday, July 18, 2012 11:55 AM
So after the new tank, Things are looking pretty good. Before with the "stock" cobalt setup in there, the system was at its peak temp less then a mile from home. and would stay within 2-3 degrees while cruising, and would always come back to that same temp after a pull. 3 days ago in 100* weather, i was seeing 129-132 on the way to work while cruising, after it was at temp. Today on the way to work, in 101* it reached 122 about a mile before i go to work. So id say that just introducing more liquid into the system make a big big big difference.



Re: The History of the EvoFire
Wednesday, July 18, 2012 1:10 PM
EvoFire wrote:

Tinkles(KGM) wrote:

Holy @!#$ is that snug in there.


yup bit it fits and fits good! putting 90s on the top two bungs and i will look a lot better.


Not sure if you'll fit two 90's in there, maybe have to run either two 45's or a 90 on the battery side one and a 45 on the outer one.

Either way, that tank looks good in there.
Re: The History of the EvoFire
Wednesday, July 18, 2012 1:30 PM
they will fit. they are a lot smaller then your think. they are only -6 fittings.



Re: The History of the EvoFire
Wednesday, July 18, 2012 4:28 PM
Chris you need a new sig. Lol.



Re: The History of the EvoFire
Wednesday, July 18, 2012 4:29 PM
yeah i do....lemme see what else i have...lol



Re: The History of the EvoFire
Wednesday, July 18, 2012 4:31 PM
hows that for ya jess?



Re: The History of the EvoFire
Wednesday, July 18, 2012 7:29 PM
Lol, meh



Re: The History of the EvoFire
Wednesday, July 18, 2012 7:30 PM
then make me one! lol



Re: The History of the EvoFire
Tuesday, August 14, 2012 7:17 PM
Well the car went back to the shop, and I have it back again. Rear main seal number 3 now. I have determined i have a clog in the PCV vent system somewhere, and the dipstick was jammed up in a way that it couldnt pop, so i was popping the rear main.

Ordered a bunch of new stuff lately.

Got OEMs blower spacer, new intake manifold gasket, a new intercooler pump, and just ordered these two gauges.

Oil Pressure

Vac/Boost






Re: The History of the EvoFire
Saturday, August 18, 2012 8:12 AM
Looking good Chris. Hows it been.running with our nasty heat lately?


"Oil Leak ? What oil Leak ? Oh, Thats Just The Sweat From All The HorsePower!!"

Re: The History of the EvoFire
Wednesday, August 22, 2012 9:37 PM
run like @!#$ during the summer Thomas


Here is my pile of fun. Gonna be a fun day when i do all this..





Re: The History of the EvoFire
Wednesday, August 22, 2012 9:39 PM
That sucks.

Looks like a fun pile of parts.


"Oil Leak ? What oil Leak ? Oh, Thats Just The Sweat From All The HorsePower!!"

Re: The History of the EvoFire
Thursday, August 23, 2012 5:16 AM
I suggest not using that cork gasket and using either nothing or a paper one.
Re: The History of the EvoFire
Thursday, August 23, 2012 12:55 PM
bunch of poop


Built&Boosted moar
04 Cavalier Turbo r.i.p my baby
2nd place 2009 GM tuner bash qwick 8--holla

Re: The History of the EvoFire
Thursday, August 23, 2012 2:40 PM
Philly D wrote:

I suggest not using that cork gasket and using either nothing or a paper one.


I am going to use another stock gasket....

Matt Gorman wrote:

bunch of poop


shut your mouth!



Re: The History of the EvoFire
Sunday, August 26, 2012 5:12 PM
put in the 3787 plugs last night, car seems to like them. throttle response seems quicker and a bit more smooth. the old stockers had about 70k on then, and still looked pretty good.



Re: The History of the EvoFire
Sunday, August 26, 2012 9:27 PM
hmmmm


Built&Boosted moar
04 Cavalier Turbo r.i.p my baby
2nd place 2009 GM tuner bash qwick 8--holla

Re: The History of the EvoFire
Wednesday, August 29, 2012 11:56 PM
i got this beauty back tonight.









Re: The History of the EvoFire
Thursday, August 30, 2012 3:27 AM
You finally going to put that on or what?

Re: The History of the EvoFire
Thursday, August 30, 2012 3:52 PM
I had to buy it back from Eric. It will go on when all the other stuff does!



Re: The History of the EvoFire
Wednesday, September 05, 2012 12:47 PM
Tired of the stupid little issues, and tired of not being able to trust shops that I pay good money too. Car has been acting weird since I got it back from the shop after the 2nd rear main seal replacement.

It was starting sluggishly, and shut off really strangely, as well as having random drivability issues such as bucking on take offs no matter how I manipulated the clutch, and going random pig rich. All electronics still worked fine, lights worked fine, stereo still worked fine. Well last night at my dads house it wouldnt fire up. Got out the DMM, and the battery was at 11ish volts, and all terminals were tight and everything was cool. I started looking around, jacked car up looked at the starter wires, and all then decided just for @!#$s and giggles to look at the ground bolt on top of the trans, and it was hanging on by only 1 thread. Tightened it up, push started the car, and everything was good to go. battery was charging, and alternator was alternating (lol). I hate how one 15mm bolts can cause so many damn issues. I think I am going to go for a big 3 or 4 or 5 ground strap project soon.



Re: The History of the EvoFire
Wednesday, September 05, 2012 5:40 PM
I say that you need to get the ported blower on it and start beating the piss out of it. Beat it soo bad that it'll be afraid to act up again.



Re: The History of the EvoFire
Wednesday, September 05, 2012 5:48 PM
Evo I had a simular issue with tha ground on the trans bolt with my car when I had simular issues. Though my factory ring termina had loose wires in it. Drove me to the point of almost selling the car last winter. I just soldered it once we finall found the issue. I'm with Tinkles though....needs a good raping got to keep hoes in check...







Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search