ECOTEC REFLASH solved! here w/ pics - Page 3 - Tuning Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Re: ECOTEC REFLASH solved! here w/ pics
Wednesday, March 29, 2006 8:15 PM
okay sounds dumb, but were does this go?




Re: ECOTEC REFLASH solved! here w/ pics
Monday, April 03, 2006 5:12 PM
got my sensor today.

I'll be trying the reflash asap.



"Growing old is mandatory. Growing up? Definitely optional."
Re: ECOTEC REFLASH solved! here w/ pics
Monday, April 03, 2006 7:37 PM
sweet. keep us updated. so are we for sure if its a 2 or 3 bar?



Re: ECOTEC REFLASH solved! here w/ pics
Monday, April 03, 2006 9:02 PM
reflash will happen tomorrow evening



*************Yea i spell liek wrong get over it*****************
** If i write in caps its cause im @ work and i can only write in caps cause the keyboard is a retarded CAPS only keyboard.**
Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 8:09 AM
I tried to do the reflash Saturday using the PCM engine calibration code - gm computer didn't like it. VCI is the only way go get this calibration, huh? How are the tech geeks on the other end? a PITA or what??



Check out my Part Out List!! Great Prices !! http://www.j-body.org/classifieds/detail/52925/

Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 8:53 AM
I installed the new map sensor.

I used the stock sensor mounting point.



"Growing old is mandatory. Growing up? Definitely optional."
Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 10:36 AM


Here are some picture of my map sensor install...

First I drilled the hole out to 31/64 because the original hole was too small.

I took my throttle body off and put a bag under the hole to catch the plastic shavings while drilling.

The sensor fits very snug inside the 31/64" hole. You have to put a small amount of pressure on it to get it in.

I then used a piece of metal that I measured, cut and bent to help hold the sensor in. This bracket is held in place by the intake manifold bolt nearest to the sensor.


Sensor and bracket installed








Under side of bracket




Finished product






Here are a few pictures of my engine bay.




Notice that my oil feed is solid I am using the saab oil feed and drain.






I can probably make more of these brackets. If I did they would look much nicer rather than just a hacked piece of metal strap.






"Growing old is mandatory. Growing up? Definitely optional."
Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 10:49 AM
Brandoson - 13.82@99.88 wrote:

First I drilled the hole out to 31/64 because the original hole was too small


Thanks for the measurments!! That should help when I go to mount mine...



Check out my Part Out List!! Great Prices !! http://www.j-body.org/classifieds/detail/52925/

Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 11:03 AM
no problem.

you wont even need that little rubber jobby thingy.



"Growing old is mandatory. Growing up? Definitely optional."
Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 6:28 PM
ITS ALIVE....AND IT WORKS


Reflash install was succesful........car runs great. Really rich but the fmu was still hooked up while this was running.

so...............
fmu + reflash = afr of 10.5-10.4
fmu hose unplugges = afr was 11.4-11.5

this was on 5 psi


brandoson is gonna remove the fmu and turn the boost up tongiht to see what the numbers will be.




*************Yea i spell liek wrong get over it*****************
** If i write in caps its cause im @ work and i can only write in caps cause the keyboard is a retarded CAPS only keyboard.**
Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 7:42 PM
I actually wont have time to remove the FMU tonight. Sonya had dinner ready so I went home instead.

I did however turn the boost up to 8psi. It ran at 10.4 afr and stayed there the entire time. Removing the fmu should help lean it out some. I really hope to get it between 11.5-12.0

with the fmu vacuum hose unplugged I thought it was between 11.2-11.4 on 5psi.

It idles very smooth with the saab 9-3t green tops (370cc). Before the reflash it ran extremely rich and rough with them at idle.



"Growing old is mandatory. Growing up? Definitely optional."

Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 8:30 PM
Quote:



I actually wont have time to remove the FMU tonight. Sonya had dinner ready so I went home instead.

I did however turn the boost up to 8psi. It ran at 10.4 afr and stayed there the entire time. Removing the fmu should help lean it out some. I really hope to get it between 11.5-12.0

with the fmu vacuum hose unplugged I thought it was between 11.2-11.4 on 5psi.

It idles very smooth with the saab 9-3t green tops (370cc). Before the reflash it ran extremely rich and rough with them at idle.


good to know. now you have an 02 with an 02 fuel rail correct? what injectors would have to be used with an 04 and 04 rail? since the saab 9-3t injectors are different. i dont believe they can be used in the 03+ rail? so im wondering what was used in the GM sc kit.

i know its been posted but since you have it done and running. what are the part numbers for the sensor and actual reflash? err. well part numbers of everything u used.
can anyone confirm if its a 2 bar or 3 bar sensor?



Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 8:39 PM
forgot to add, reflash cost? final price with everything?

a long shot but did it bump the limiter up to 7000 or affect the gov?



Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 8:40 PM
he is running the green top saab injectors on the 2002 rail.

i have the saab injecotrs on an 04 rail..you just need the lil spacers for the injectors


the part number is listed on the first page along with the connectors.
_


*************Yea i spell liek wrong get over it*****************
** If i write in caps its cause im @ work and i can only write in caps cause the keyboard is a retarded CAPS only keyboard.**
Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 8:43 PM
part number for? the clips?



Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 8:49 PM
Awesome!! Now I want to bang in sick to work tomorrow and go get the reflash and take my FMU off!!



Check out my Part Out List!! Great Prices !! http://www.j-body.org/classifieds/detail/52925/

Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 8:49 PM
Couple questions for brandon:

Did you hook up the water lines?

How did you get the downpipe made?

and you got the saab tb hose on and rerouted the ic pipes?



Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 9:30 PM
I know im not brandon but i know the answers.

Did you hook up the water lines? No they are not hooked up

How did you get the downpipe made? we customade one....It took about 3-4 tries but we made it out of 2.5inch pipe...and it clears the waterlines.

and you got the saab tb hose on and rerouted the ic pipes?
yeap....we got the hose from your one post, it clears the hood, and it goes down under the battery box between the front trans mount and radiator, from there it goes to the intercooler.

the inlet on the hose is 2" diameter.

Its hard to say: John H [Cavalierkid] but look at the very first post in this thread by me on page 1..it tells everything that you will need, and how to do it. including wiring scematics and connecot end views


Quote:

You will need these 2 things:
1. TMAP Sensor(Temperature/ Manifold Absolute Pressure) ....................Part # 90423637
2. Connector for the TMAP(Complete w/ Wiring)...........................................Part # 88988320
(We have confirmed this by looking @ sensors in the 17800003 supercharger package)
You will need to use this Diagram To do the wiring.












*************Yea i spell liek wrong get over it*****************
** If i write in caps its cause im @ work and i can only write in caps cause the keyboard is a retarded CAPS only keyboard.**
Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 9:38 PM
Also brandoson installed the new map sensor with the stock pcm and it ran fine...he drove atleast 20 miles to my dealership w/ no problems


*************Yea i spell liek wrong get over it*****************
** If i write in caps its cause im @ work and i can only write in caps cause the keyboard is a retarded CAPS only keyboard.**
Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 10:59 PM
thanks snowman. got the number for the connector and sensor, but whats the acutal number for the reflash itself?



Re: ECOTEC REFLASH solved! here w/ pics
Tuesday, April 04, 2006 11:55 PM
dealers gotta call for the reflash #


and the part #'s are in the fpic above








Re: ECOTEC REFLASH solved! here w/ pics
Wednesday, April 05, 2006 11:00 AM
BEWARE! : Do NOT try boosting with the new map sensor before the reflash. It runs extremely lean. Even if you have an fmu or some other form of fuel adjustment.

Install the sensor and drive like a grandma to the dealer for the reflash.

I just dont want anyone thinking it will run the same as the stock sensor without the reflash.


Quote:

How did you get the downpipe made? we customade one....It took about 3-4 tries but we made it out of 2.5inch pipe...


actually it only took 2 tries. haha. The first time we made it, it was too close to the shift cables and rubbed them. The second time I modified it and it fit nicely.

Later on we added a flexpipe and changed the last angle a bit. So I guess it was 3 times.



I removed the FMU. I am going to take it out for a test run and see what kind of afr's i see.



"Growing old is mandatory. Growing up? Definitely optional."
Re: ECOTEC REFLASH solved! here w/ pics
Wednesday, April 05, 2006 11:02 AM
Congrats Brandon.







Re: ECOTEC REFLASH solved! here w/ pics
Wednesday, April 05, 2006 11:19 AM
Just came back from a test run.

under boost at 8.2 psi it stayed dead on 11.2 afr for most of the time.

I am installing the LM1 Manager on my work computer to download the recorded data to get a chart for you guys.



"Growing old is mandatory. Growing up? Definitely optional."
Re: ECOTEC REFLASH solved! here w/ pics
Wednesday, April 05, 2006 11:28 AM



Check out my Part Out List!! Great Prices !! http://www.j-body.org/classifieds/detail/52925/

Forum Post / Reply
You must log in before you can post or reply to messages.

 

Start New Topic Advanced Search